LUCI displays 4 LAN ports, really 3.
Can you provide more details, e.g. describe the names, etc. of the extra port.
PIC or it didn't happen...
Can you post the content of your /etc/config/network
file? Make sure to redact any private information.
The default config has 4 ports, instead of 3
Summary
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd8d:2efb:7057::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.61.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'pppoe'
option username 'login'
option password 'passwd'
option ipv6 'auto'
Yes, it lists lan4
in your bridge, that's the reason. And I'm pretty sure the cause is the following:
This device is missing from target/linux/ramips/mt7621/base-files/etc/board.d/02_network
and it falls-through to
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
while lan4
doesn't exist. This was probably overlooked when adding support for the device.
Can you compile your own image with the device added to this file? And create a PR if it works?
Can you compile your own image with the device added to this file? And create a PR if it works?
I don't understand this screenshot, what are you trying to point out?
These are the settings in the 2.4GHz tab.
I don't see anything wrong about the 2.4 GHz wireless, 802.11ax is valid for 2.4 GHz (and the device naming is cosmetic anyways; legacy/n/ax is valid).
The scanner (inSSIDer) only shows g, n and b if enabled in the settings and does not show AX. This router also supports AC, but is also not available in the selection.
Do one step after the other, please: Can you compile an image and test if the change really fixes the LAN port overview and create a PR afterwards? We have a good guess what's wrong, but that doesn't help if a fix isn't pushed.
compile SNAPSHOT and check changes?
@nicefile I think you were the one who added initial support for this device. Are you still around and can check if this fixes the issue with LuCI?
If itβs not difficult for you, compile the image with your edits so that the experiment is 100% successful.
List of packages used on this router:
Summary
base-files
bridger
busybox
ca-bundle
cgi-io
dnscrypt-proxy2
dnsmasq-full
dropbear
firewall4
fstools
fwtool
getrandom
hostapd-common
iw
iwinfo
jansson4
jshn
jsonfilter
kernel
kmod-cfg80211
kmod-crypto-acompress
kmod-crypto-aead
kmod-crypto-ccm
kmod-crypto-cmac
kmod-crypto-crc32c
kmod-crypto-ctr
kmod-crypto-gcm
kmod-crypto-gf128
kmod-crypto-ghash
kmod-crypto-hash
kmod-crypto-hmac
kmod-crypto-kpp
kmod-crypto-lib-chacha20
kmod-crypto-lib-chacha20poly1305
kmod-crypto-lib-curve25519
kmod-crypto-lib-poly1305
kmod-crypto-manager
kmod-crypto-null
kmod-crypto-rng
kmod-crypto-seqiv
kmod-crypto-sha512
kmod-gpio-button-hotplug
kmod-hwmon-core
kmod-leds-gpio
kmod-lib-crc-ccitt
kmod-lib-crc32c
kmod-lib-lzo
kmod-mac80211
kmod-mt76-connac
kmod-mt76-core
kmod-mt7915-firmware
kmod-mt7915e
kmod-nf-conntrack
kmod-nf-conntrack-netlink
kmod-nf-conntrack6
kmod-nf-flow
kmod-nf-log
kmod-nf-log6
kmod-nf-nat
kmod-nf-reject
kmod-nf-reject6
kmod-nfnetlink
kmod-nft-core
kmod-nft-fib
kmod-nft-nat
kmod-nft-offload
kmod-ppp
kmod-pppoe
kmod-pppox
kmod-sched-act-vlan
kmod-sched-bpf
kmod-sched-core
kmod-sched-flower
kmod-slhc
kmod-thermal
kmod-udptunnel4
kmod-udptunnel6
kmod-wireguard
libblobmsg-json20230523
libbpf1
libc
libelf1
libgcc1
libgmp10
libiwinfo-data
libiwinfo20230701
libjson-c5
libjson-script20230523
liblucihttp-ucode
liblucihttp0
libmbedtls12
libmnl0
libnetfilter-conntrack3
libnettle8
libnfnetlink0
libnftnl11
libnl-tiny1
libpthread
libubox20230523
libubus20220615
libuci20130104
libuclient20201210
libucode20220812
libustream-mbedtls20201210
logd
luci
luci-app-firewall
luci-app-opkg
luci-base
luci-i18n-base-ru
luci-i18n-firewall-ru
luci-i18n-opkg-ru
luci-light
luci-mod-admin-full
luci-mod-network
luci-mod-status
luci-mod-system
luci-proto-ipv6
luci-proto-ppp
luci-proto-wireguard
luci-ssl
luci-theme-bootstrap
mtd
netifd
nftables-json
odhcp6c
odhcpd-ipv6only
openwrt-keyring
opkg
ppp
ppp-mod-pppoe
procd
procd-seccomp
procd-ujail
px5g-mbedtls
rpcd
rpcd-mod-file
rpcd-mod-iwinfo
rpcd-mod-luci
rpcd-mod-rrdns
rpcd-mod-ucode
ubi-utils
ubox
ubus
ubusd
uci
uclient-fetch
ucode
ucode-mod-fs
ucode-mod-html
ucode-mod-math
ucode-mod-ubus
ucode-mod-uci
uhttpd
uhttpd-mod-ubus
urandom-seed
urngd
usign
wireguard-tools
wireless-regdb
wpad-mbedtls
zlib
Thank you!!!
Yes I'm here
look that this what we missing from /etc/board.d/02_network
mercusys,mr70x-v1)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
;;
@Lexeyko can You please add above to the /etc/board.d/02_network , remove /etc/config/network and reboot ?
it should default back to lan1 lan2 lan3 as it should
I did, but it didn't solve the problem. There are 4 LANs
Part of the file with corrections
Summary
zyxel,lte3301-plus)
ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
;;
mercusys,mr70x-v1)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
;;
mikrotik,routerboard-750gr3)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
;;
remove /etc/config/network
and /etc/board.json
and do reboot . And use "in-private" / "incognito" browser mode to log to router 192.168.1.1