BUFFALO WSR-1166DHP2 - How to fix strange filesystem

Hello,
I installed OpenWrt on WSR-1166DHP2 following this site: https://okoya.seesaa.net/article/460490117.html (sorry it's japanese site)
It seems installation was correctly finished but any changes won't be kept after rebooting. For example, when I fixed /etc/config/network file, After rebooting it rolled back.

Also package installation via opkg fails like below:

opkg install luci
Installing luci (git-23.051.66410-a505bb1) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
 * opkg_install_cmd: Cannot install package luci.

So I checked my filesystem and found it may be strange.

df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    61.0M   1004.0K     60.0M   2% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

There isn't /overlay, only tmpfs.
I think this may be the cause of these issues... Does anyone know any solutions or hints?

Which image did you use, and from where ?
https://openwrt.org/toh/buffalo/wsr-1166dhp ?

I installed OpenWrt on WSR-1166DHP2 following this site: https://okoya.seesaa.net/article/460490117.html (sorry it's japanese site)

At first, following this site I downloaded and wrote lede-ramips-mt7621-wsr-1166dhp2-initramfs-factory.bin from https://web.archive.org/web/20220324021906/http://naobsd.org/lede-openwrt/ via official Web GUI. After that from CUI I tried to install the image which you showed, but somehow sysupgrade showed message like "Device WSR-1166 don't compatible with this image" (it's inaccurate), so I used this: https://downloads.openwrt.org/releases/17.01.4/targets/ramips/mt7621/lede-17.01.4-ramips-mt7621-wsr-1166-squashfs-sysupgrade.bin ,which is same version as first one.