Buffalo WHR-HP-G300n "dumb ap" - SSH connection times out on vLAN

Buffalo WHR-HP-G300n. Running OpenWRT LEDE 18.06.1.

4 vLANs configured. 3 vAPs configured. Each vLAN is bridged to it's corresponding vAP, except for the "Management" vLAN. All vLANs are connected to a single uplink port, in a "trunk" configuration.

root@ap-buffalo1:~# cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd21:4795:b47a::/48'

config interface 'vlan24'
        option type 'bridge'
        option ifname 'eth0.24'
        option proto 'static'
        option ipaddr '10.10.24.51'
        option netmask '255.255.255.0'

config interface 'vlan88'
        option type 'bridge'
        option ifname 'eth0.88'
        option proto 'static'
        option ipaddr '10.10.88.51'
        option netmask '255.255.255.0'

config interface 'vlan128'
        option type 'bridge'
        option ifname 'eth0.128'
        option proto 'static'
        option ipaddr '10.10.128.51'
        option netmask '255.255.255.0'

config interface 'vlan200'
        option type 'bridge'
        option ifname 'eth0.200 eth1'
        option proto 'static'
        option ipaddr '10.10.200.51'
        option netmask '255.255.255.0'
        option gateway '10.10.200.1'
        option dns '10.10.200.1'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1'

config switch_vlan 'eth0_1'
        option device 'switch0'
        option vlan '2'
        option vid '24'
        option ports '0t 1t 2 3 4'

config switch_vlan 'eth0_2'
        option device 'switch0'
        option vlan '3'
        option vid '88'
        option ports '0t 1t'

config switch_vlan 'eth0_3'
        option device 'switch0'
        option vlan '4'
        option vid '128'
        option ports '0t 1t'

config switch_vlan 'eth0_4'
        option device 'switch0'
        option vlan '5'
        option vid '200'
        option ports '0t 1t'

root@ap-buffalo1:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option country 'US'
        option channel '9'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'My Internet Is Faster Than Yours'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'vlan24'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'Reyna Is A Freeloader'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'vlan88'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenVPN Access'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'vlan128'

From my laptop on my "Private" vLAN (vid=24), I can connect to the AP on that interface via SSH and not have any issues. I ultimately want to only have a configuration IP on the "management" vlan (vid=200). When I try to connect with my laptop to the management interface of the AP, the connection drops after 20-30 seconds.

I doubt I have a routing issue, since I'm able to hold a connection to any other device in the management interface.
I've even created a debian VM and placed it on the management interface. It can connect to the management interface on the AP without issue as well.

I'm a bit stumped. Any ideas?

Edit:
I just ran a 'netstat -n' on the buffalo router. My laptop (10.10.24.100) only has one SSH client session running. Why is the AP showing an active connection from my laptop to it's management interface?

root@ap-buffalo1:~# netstat -n
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0  27852 10.10.200.51:22         10.10.24.100:58322      ESTABLISHED
tcp        0    304 10.10.24.51:22          10.10.24.100:58319      ESTABLISHED

It's gone now.. The connection timeout must have taken a bit to be reflected in netstat. This is seeming more and more like a routing issue, not on the AP itself.

I did another SSH connection from another box on my vid=24 subnet. It drops the SSH connection to the AP as well, around the same time frame.

So, in summary.
All machines on my vid=24 subnet can't keep a connection to the AP on the vid=200 subnet for longer than 30 seconds.
I can keep a connection from the vid=24 subnet to a different machine on the vid=200 subnet.
The AP can keep a connection to any other machine I've attempted to ssh, no matter the target machine's subnet.