Buffalo Linkstation does not store config changes and always boots into inital configuration

I yesterday installed OpenWRT on a Buffalo Linkstation LS421DE like described on the wiki page.
I am experienced with different Linux Distros but a newbie to OpenWRT.

My problem: I want to use the Linkstation as a NAS and as a DHCP Client without any network services (published to my network) but after rebooting the device dnsmasq, firewall and odhcpd are present again although I previously killed the processes and disabled the deamons in the "Startup" section of LuCI.

Did I miss something? Do I have to do anything to make these changes persistent?
Perhaps I can go on the CLI and configure it there "the linux style", but I want to ensure that the box does not break my network after the next OpenWRT upgrade because it then starts the services again. So i would like to configure it the way OpenWRT expects.

Another thing that seems odd to me: I always get the information that the root password is empty and has to be set although I already set one and log in using this password.

Thank you in advance!

It looks like the changes you apply are not saved and on every boot the system starts with the initial configuration.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
mount; df

OK, you are right, there seems to be no persistent volume. I will carefully read again the wiki page - perhaps it was too late last night :wink:

Here's the output:

root@OpenWrt:~# ubus call system board;
        "initramfs": true,
        "kernel": "5.4.143",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "Buffalo LinkStation LS421DE",
        "board_name": "buffalo,ls421de",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.0",
                "revision": "r16279-5cc0535800",
                "target": "mvebu/cortexa9",
                "description": "OpenWrt 21.02.0 r16279-5cc0535800"
root@OpenWrt:~# moun
-ash: moun: not found
root@OpenWrt:~# mount
tmpfs on / type tmpfs (rw,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                   254720      9072    245648   4% /
tmpfs                   254720       220    254500   0% /tmp
tmpfs                      512         0       512   0% /dev

As you noticed, tmpfs is on the ram and won't survive a reboot.

1 Like

Might this be the result when the sysupgrade didn't work?
Perhaps I rebooted the system too fast.
How can I ensure that the sysupgrade has finished? After invoking the command it immediately closes the ssh session so that I'm blind at this point...

This is the instruction I followed: https://openwrt.org/toh/buffalo/ls421de

looks like you didn't make it to step 8 ( download sysupgrade and flash it? )... if you tried that... could be that it's not sticking for some reason (did you do step 7 ok?, nevermind says optional)... so you may need to pass -v or use a serial console for more info...


Yeah, per ssh I only see

root@OpenWrt:/tmp# sysupgrade -n openwrt-21.02.0-mvebu-cortexa9-buffalo_ls421de-squashfs-sysupgrade.bin 
Wed Sep  1 00:51:26 UTC 2021 upgrade: Commencing upgrade. Closing all shell sessions.
Connection to closed by remote host.
Connection to closed.

Perhaps I should be more patient :wink:

I guess the upgrade finishes without interactive session? I tried to start the upgrade in a screen session put screen is not available by default.

I omitted step 7 because going back to the original firmware is no option. I want to use ssh or rsync, perhaps NFS to backup data to the box, and Buffalo only supports ftp or a very old samba implementation in their latest stock firmware...

In the meantime I tried again giving it more time to finish. It seems as if the Linkstation restarts automatically (other than mentioned in the article),
But it again only boots into the ramfs :frowning:

OMG. I got it. The System booted from hard disk all the time :man_facepalming:.
And of course there was the initramfs present with which I replaced the original from Buffalo.
After pulling out both disks and starting again everything went fine :smiley:

Perhaps someone could clarify in the documentation that

Remove the hard drive. Keep it apart if you want back to the stock firmware later.

is important not only to those who want to preserve the stock configuration :slight_smile:

I missed that because I don't want to keep anything from the original firmware and content but did not get that point, that the system keeps booting from disk as long as it is not formated...

Thank you all for your quick responses!


I appended the wiki for clarification.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.