BT hub 5A : WAN LAN settings - New Setup

I have a new BTHUB5 based openwrt router. I can connect to TalkTalk, but neither LAN nor WIFI can connect to internet. What I want is to have the home network using the 192.168.0.xxx range with connected devices a mix of fixed IP and dynamically assigned IP's to guest devices. I'd also like to use google (8.8.8.8) as my primary DNS services, and TalkTalk's DNS as the secondary.

I've looked through similar "answers" on the forum but they don't seem to work. Nor did the Troubleshooting page (https://openwrt.org/docs/guide-quick-start/troubleshooting_internetconnectivity)

I am happy editing the etc/config/network settings. Or making changes via GUI.

Any help would be appreicated.

you should post your configuration files, cat /etc/config/network so we can see dsl configuration..

You mean the router has internet access? Can you, for example, ping 8.8.8.8 from within the router? How about any known domain?

Please post the output of the following commands. Remember to redact passwords, MAC adresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Hi. Thank you for feedback. Yes, if I use diagnostic within openwrt then I can successfully ping/tracert to 8.8.8.8 and www.google.com.

I am pasting my config settings below

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd56:6a0f:527d::/48'

config dsl 'dsl'
option annex 'a'
option tone 'av'

config interface 'wan'
option proto 'dhcp'
option ifname 'dsl0.101'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr '34:8a:ae:ca:f6:2e'

config device 'wan_dsl0_dev'
option name 'dsl0'
option macaddr '34:8a:ae:ca:f6:2f'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 6t'

config interface 'wwan'
option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
option htmode 'VHT80'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'KoKoKat-OpenWrt'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'pci0000:00/0000:00:0e.0'
option htmode 'HT20'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'KoKoKat-OpenCat'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
option tone 'av'

config interface 'wan'
option proto 'dhcp'
option ifname 'dsl0.101'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr '34:8a:ae:ca:f6:2e'

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6 wwan'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_typconfig device 'wan_dsl0_dev'
e 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

    option name 'dsl0'

root@OpenWrt:~# config interface 'loopback'
-ash: config: not found
root@OpenWrt:~# option ifname 'lo'

-ash: option: not found
root@OpenWrt:~# option proto 'static'
-ash: option: not found
root@OpenWrt:~# option ipaddr '127.0.0.1'
-ash: option: not found
root@OpenWrt:~# option netmask '255.0.0.0'
-ash: confioption: not foundg switch

root@OpenWrt:~#
root@OpenWrt:~# config globals 'globals'
-ash: config: not found
root@OpenWrt:~# option ula_prefix 'fd56:6a0f:527d::/48'
-ash: option device 'switch0'
option: not found
root@OpenWrt:~#
root@OpenWrt:~# config dsl 'dsl'
option ports '0 1 2 4 6t'
-ash: config: not found
root@OpenWrt:~# option annex 'a'
config switch_vlan
-ash: option: not found
root@OpenWrt:~# option tone 'av'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config interface 'wan'
-ash: config: not found
root@OpenWrt:~# option proto 'dhcp'
-ash: option: not found
root@OpenWrt:~# option ifname 'dsl0.101'
-ash: config wifi-iface 'default_radio0'
option: not found
root@OpenWrt:~#
root@OpenWrt:~#
root@OpenWrt:~# config interface 'lan'
-ash: config: not found option encryption 'none'

root@OpenWrt:~# option type 'bridge'
-ash:
option: not found
root@OpenWrt:~# option ifname 'eth0.1'
config dnsmasq
-ash: option: not found
option domainneeded '1'
root@OpenWrt:~# option proto 'static'
option nonegcache '0'
-ash: option: not found
option authoritative '1'
root@OpenWrt:~# option ipaddr '192.168.1.1'
-ash: option: not found
option leasetime '12h'
root@OpenWrt:~# option netmask '255.255.255.0'
-ash: option: not found
option loglevel '4'
root@OpenWrt:~# option ip6assign '60'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config device 'lan_eth0_1_dev'
-ash: config: not found
root@OpenWrt:~# option name 'eth0.1'
-ash: option: not found
root@OpenWrt:~# option macaddr '34:8a:ae:ca:f6:2e'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config device 'wan_dsl0_dev'
-ash: config: not found
root@OpenWrt:~# option name 'dsl0'
-ash: option: not found
root@OpenWrt:~# option macaddr '34:8a:ae:ca:f6:2f'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config interface 'wan6'
-ash: config: not found
root@OpenWrt:~# option ifname '@wan'
-ash: option: not found
root@OpenWrt:~# option proto 'dhcpv6'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config switch
-ash: config: not found
root@OpenWrt:~# option name 'switch0'
-ash: option: not found
root@OpenWrt:~# option reset '1'
-ash: option: not found
root@OpenWrt:~# option enable_vlan '1'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config switch_vlan
-ash: config: not found
root@OpenWrt:~# option device 'switch0'
-ash: option: not found
root@OpenWrt:~# option vlan '1'
-ash: option: not found
root@OpenWrt:~# option ports '0 1 2 4 6t'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config switch_vlan
-ash: config: not found
root@OpenWrt:~# option device 'switch0'
-ash: option: not found
root@OpenWrt:~# option vlan '2'
-ash: option: not found
root@OpenWrt:~# option ports '5 6t'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config interface 'wwan'
-ash: config: not found
root@OpenWrt:~# option proto 'dhcp'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# root@OpenWrt:~# cat /etc/config/wireless
-ash: root@OpenWrt:~#: not found
root@OpenWrt:~#
root@OpenWrt:~# config wifi-device 'radio0'
-ash: config: not found
root@OpenWrt:~# option type 'mac80211'
-ash: option: not found
root@OpenWrt:~# option channel '36'
-ash: option: not found
root@OpenWrt:~# option hwmode '11a'
-ash: option: not found
root@OpenWrt:~# option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
-ash: option: not found
root@OpenWrt:~# option htmode 'VHT80'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config wifi-iface 'default_radio0'
-ash: config: not found
root@OpenWrt:~# option device 'radio0'
-ash: option: not found
root@OpenWrt:~# option network 'lan'
-ash: option: not found
root@OpenWrt:~# option mode 'ap'
-ash: option: not found
root@OpenWrt:~# option encryption 'none'
-ash: option: not found
root@OpenWrt:~# option ssid 'KoKoKat-OpenWrt'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config wifi-device 'radio1'
-ash: config: not found
root@OpenWrt:~# option type 'mac80211'
-ash: option: not found
root@OpenWrt:~# option channel '11'
-ash: option: not found
root@OpenWrt:~# option hwmode '11g'
-ash: option: not found
root@OpenWrt:~# option path 'pci0000:00/0000:00:0e.0'
-ash: option: not found
root@OpenWrt:~# option htmode 'HT20'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config wifi-iface 'default_radio1'
-ash: config: not found
root@OpenWrt:~# option device 'radio1'
-ash: option: not found
root@OpenWrt:~# option network 'lan'
-ash: option: not found
root@OpenWrt:~# option mode 'ap'
-ash: option: not found
root@OpenWrt:~# option encryption 'none'
-ash: option: not found
root@OpenWrt:~# option ssid 'KoKoKat-OpenCat'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# root@OpenWrt:~# cat /etc/config/dhcp
-ash: root@OpenWrt:~#: not found
root@OpenWrt:~#
root@OpenWrt:~# config dnsmasq
-ash: config: not found
root@OpenWrt:~# option domainneeded '1'
-ash: option: not found
root@OpenWrt:~# option boguspriv '1'
-ash: option: not found
root@OpenWrt:~# option filterwin2k '0'
-ash: option: not found
root@OpenWrt:~# option localise_queries '1'
-ash: option: not found
root@OpenWrt:~# option rebind_protection '1'
-ash: option: not found
root@OpenWrt:~# option rebind_localhost '1'
-ash: option: not found
root@OpenWrt:~# option local '/lan/'
-ash: option: not found
root@OpenWrt:~# option domain 'lan'
-ash: option: not found
root@OpenWrt:~# option expandhosts '1'
-ash: option: not found
root@OpenWrt:~# option nonegcache '0'
-ash: option: not found
root@OpenWrt:~# option authoritative '1'
-ash: option: not found
root@OpenWrt:~# option readethers '1'
-ash: option: not found
root@OpenWrt:~# option leasefile '/tmp/dhcp.leases'
-ash: option: not found
root@OpenWrt:~# option resolvfile '/tmp/resolv.conf.auto'
-ash: option: not found
root@OpenWrt:~# option nonwildcard '1'
-ash: option: not found
root@OpenWrt:~# option localservice '1'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config dhcp 'lan'
-ash: config: not found
root@OpenWrt:~# option interface 'lan'
-ash: option: not found
root@OpenWrt:~# option start '100'
-ash: option: not found
root@OpenWrt:~# option limit '150'
-ash: option: not found
root@OpenWrt:~# option leasetime '12h'
-ash: option: not found
root@OpenWrt:~# option dhcpv6 'server'
-ash: option: not found
root@OpenWrt:~# option ra 'server'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config dhcp 'wan'
-ash: config: not found
root@OpenWrt:~# option interface 'wan'
-ash: option: not found
root@OpenWrt:~# option ignore '1'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config odhcpd 'odhcpd'
-ash: config: not found
root@OpenWrt:~# option maindhcp '0'
-ash: option: not found
root@OpenWrt:~# option leasefile '/tmp/hosts/odhcpd'
-ash: option: not found
root@OpenWrt:~# option leasetrigger '/usr/sbin/odhcpd-update'
-ash: option: not found
root@OpenWrt:~# option loglevel '4'
-ash: option: not found
root@OpenWrt:~# config interface 'lan'
-ash: config: not found
option ip6assign '60'
root@OpenWrt:~# option type 'bridge'
-ash: option: not found
root@OpenWrt:~# option ifname 'eth0.1'
-ash: option: not found
option forward 'ACCEPT'
root@OpenWrt:~# option proto 'static'
-ash: option: not found
root@OpenWrt:~# option ipaddr '192.168.1.1'
-ash: config zone
option: not found
root@OpenWrt:~# option netmask '255.255.255.0'
-ash: option: not found
root@OpenWrt:~# option ip6assign '60'
option name 'wan'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config device 'lan_eth0_1_dev'
option output 'ACCEPT'
-ash: config: not found
root@OpenWrt:~# option name 'eth0.1'
option forward 'REJECT'
-ash: option: not found
root@OpenWrt:~# option macaddr '34:8a:ae:ca:f6:2e'
option mtu_fix '1'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~#
root@OpenWrt:~# config defaults
-ash: config: not found
root@OpenWrt:~# option syn_flood '1'
-ash: option: not found
root@OpenWrt:~# option input 'ACCEPT'
-ash: option: not found

root@OpenWrt:~# option output 'ACCEPT'
option name 'Allow-DHCP-Renew'
-ash: option: not found
root@OpenWrt:~# option forward 'REJECT'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config zone
-ash: config: not found
root@OpenWrt:~# option name 'lan'
option src 'wan'
-ash: option: not found
root@OpenWrt:~# option input 'ACCEPT'
-ash: option: not found
root@OpenWrt:~# option output 'ACCEPT'
option src 'wan'
-ash: option: not found
root@OpenWrt:~# option forward 'ACCEPT'
-ash: option: not found

root@OpenWrt:~# option network 'lan'
-ash: option: not found
option dest_ip 'fc00::/6'
root@OpenWrt:~#
option dest_port '546'
root@OpenWrt:~# config zone
-ash: config: not found
root@OpenWrt:~# option name 'wan'
option src 'wan'
-ash: option: not found
root@OpenWrt:~# option input 'REJECT'
-ash: option: not found
root@OpenWrt:~# option output 'ACCEPT'
-ash: option: not found
root@OpenWrt:~# option forward 'REJECT'
-ash: option: not found
option proto 'icmp'
root@OpenWrt:~# option masq '1'
-ash: option: not found
root@OpenWrt:~# option mtu_fix '1'
list icmp_type 'packet-too-big'
-ash: option: not found
root@OpenWrt:~# option network 'wan wan6 wwan'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config forwarding
-ash: config: not found
root@OpenWrt:~# option src 'lan'
list icmp_type 'neighbour-advertisement'
-ash: option: not found
root@OpenWrt:~# option dest 'wan'
-ash: option: not found
root@OpenWrt:~#
root@OpenWrt:~# config rule
-ash: config: not found
root@OpenWrt:~# option name 'Allow-DHCP-Renew'
-ash: option: not found
root@OpenWrt:~# option src 'wan'
list icmp_typconfig device 'wan_dsl0_dev'
-ash: option: not found
root@OpenWrt:~# option proto 'udp'
list icmp_type 'packet-too-big'
-ash: option: not found
root@OpenWrt:~# option dest_port '68'
-ash: option: not found
root@OpenWrt:~# option target 'ACCEPT'
-ash: option: not found
root@OpenWrt:~# option family 'ipv4'
-ash: option: not found option src 'wan'

You have too much of excess output at the end. You might want to delete that. And please use the "Preformatted text </>" button for logs, scripts, configs ad eneral console output.grafik

I should have mentioned that earlier.

The default LAN IP of OpenWrt is 192.168.1.1.

If a user changes that IP in LuCI, there is a safety feature designed to ensure that the new IP is accessible by the device after the user applies the change. So if the new IP is on a different subnet other than the current subnet, after 30 seconds of trying, the user will be presented with an option to Apply Unchecked or Revert to the old IP.

If you don't take chances and you don't wish to Apply Unchecked, then immediately after you change the IP and apply, you renew your computer IP (for example disconnect and reconnect, whether it's wired or wireless) then you edit the router IP in the browser address bar to the new IP. That way the PC will find the router accessible on the new IP and therefore the IP change will not be reverted.

Alternatively, you can set two static IPs for your PC NIC adapter, say one as 192.168.1.10 and the other as 192.168.0.10 (for example), then when you change the IP of the router LAN interface, you edit the IP in the browser address bar from 192.168.1.1 to 192.168.0.1 and hit enter.