BT Homehub A, no web gui

Hi all,

Inherited helpding out support at a hackspace and trying to understand previous work from more knowleagble people who didn't see the need for documentation.

I'd like to upgrade the openwrt router but I have 2 spare there and would like to get them sorted so I can swap over and make sure I understand the process (marked as 4.4.14 which I believe is kernel making them 17.01).

Connecting to them through LAN cable I'm getting 192.168.1.0/24 address but neither has a web gui.
I can ssh into one, the other has a password.

Now I've seen I should be able to get the web gui working through

opkg update && opkg install luci

(https://openwrt.org/docs/guide-user/luci/luci.essentials)

but they're not currently connected to the internet so that fails.
Simply connecting the WAN port to the local network doesn't allow the CLI internet access ('ip a' doesn't show it's getting a network address).
Know I was hoping for a bit much there and presume I need to reconfigure network files if I want to go that route.

Or I guess I reset the one with the password and attempt to get the firmware on the device and update through ssh. Should that enable the gui by default?

Any suggestions on the more fuitful path? Or another way?

I think what's making me pause is.. why isn't the gui there?. It is on the one that's installed so I'm slightly surprised if it was a conscious choice.

There's still some rtfm to be done but I have looked at a lot so far, just drowning a bit as it's the first lede/open wrt I've looked at and I wanted to check I'm heading down the right parth please

I had limited time with them today so will go and confirm releases etc through the CLI when next back.

Thanks and hugely appreciated.

Note to self (?)..

"These instructions are not required for LEDE 17.x or OpenWRT 18.x stable, because they includes LuCI."

Post 2 on https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=145

Since you don't know what is running anyway (other than that it is OpenWrt), you should first off upgrade to a known release build, Run scp on your PC to push the firmware bin onto /tmp (RAM disk) from the LAN side then log in to the router and run sysupgrade to flash it. Use the -n option to sysupgrade to make a clean install with a reset to default configuration.

For the one that you don't know the password, you could try failsafe mode or serial terminal. By default there is no password on the serial unless it is configured otherwise.

As far as I'm aware, kernel 4.4.14 predates LEDE 17.01.0 (Feb 2017) stable release, and you perhaps have an early LEDE snapshot from around summer 2016. You won't be able to install LuCI to it any more.

To confirm, is there any other version info displayed on the welcome banner when you SSH into the hub?

Snapshot versions prior to LEDE r2363 will have a different partition layout to what is currently used by BT firmware, LEDE 17.01.0 (r3205), and OpenWRT 18.06.0 (r7090) on HH5A. You may find the wifi stops working or at worst, brick the hub if you try to install them.

The only way to convert it back to the current (OEM) partition layout is using serial console to the HH5a which usually requires soldering. See section 6 of the Guide. It cannot be done via SSH.
LEDE install guide for HH5A

Reverting to OEM partition layout
link to ebilan forum about LEDE r2363 (Nov 2016) for HH5A

If the version of LEDE snapshot is indeed from summer 2016 and you do not want to solder any wires to the HH5A, you may wish to consider jimbof's LEDE builds from that period which are still available:
jimbof LEDE snapshot builds
I believe these do have LuCI, but you won't be able to install any additional packages. r1491 was the last image he compiled. Flash these firmwares at your own risk.

Thanks both, very glad I checked now.,

@bill888 . Good warnings, thanks. I'm presuming it's been soldered to get the LEDE on there in the first place and there are wires coming out (though can't remembered if they're labelled). I'll have look.

Version

If the welcome screen isn't there I'm looking at

/etc/openwrt_release under DISTRIB_TARGET

or

LEDE_BOARD in /etc/os-release

(Just to be clear that 4.4.14 was written on a sticker on the back so may be wrong)

Reset device (for passworded ssh)

Just paperclup in reset button (if homehub has one?)

Getting on network
I'm having trouble googling this one but, as I learn these boxes, I can see the benefit of getting one working on the existing network, so I can test things remotely, before I switch one over and potentially break the existing setup.

So, rather than the WAN port expecting an adsl connection it would get DHCP from the existing working router, and then serve a different network segment to it's LAN ports (actually the default 192.168.1.x would be ok as the main network is on 172 range).
I think that would be preferable to bridging the existing network as would largely simulate the eventual PPPoE setup and may actually be useful as there are some machines I wouldn't mind putting behind an internal firewall away from wifi.

I appreciate there may be double NAT problems etc

Is this possible? Presume it's worth waiting for the gui to set that up, rather than CLI
Or am I speaking out of my arse?

AHA, I'm an idiot.

Got someone to take a photo for me and it's labelled
LEDE Kernel 4.4.61 May 2017.

So I should bi in business for a direct upgrade ??
(although I'll confirm versions through CLI)

Which makes it strange there isn't a gui, doesn't it? Anything I should be checking before reflashing .

scp image to /tmp ram - ( https://downloads.openwrt.org/releases/18.06.1/targets/lantiq/xrx200/openwrt-18.06.1-lantiq-xrx200-bt_homehub-v5a-squashfs-sysupgrade.bin)

sysupgrade -v -n /tmp/openwrt-lantiq-xrx200-BTHOMEHUBV5A-ubifs-sysupgrade.tar

cross fingers

LEDE 17.01.1 (r3316) stable was released on 24 April 2017 with 4.14.61. Probably unlikely a snapshot would be installed on the hub given the kernel revision, so should be fine to flash to latest 17.01.6 or 18.06.1 stable.

You'll have to refer to the install guide (section 9.3) with regards to enabling the red WAN port using GUI or CLI. It is disabled by default. The port is defined as eth1.2 at the time, unless it was the custom/fixed version by mkresin where it would be defined as eth0.2. (It is eth0.2 since 17.01.2 stable)

'Factory Reset' only works for squashfs images. (Unlikely anyone would use the ubifs images). Perhaps try it and see if it restores the GUI or changes any settings if you think it is 17.01.1(r3316)? See section 8 of the guide.

Thanks, understood and really appreciate the time. Can see the section 9.3 that I somehow missed now.

@beardedfool et.al. For reference, here's the UCI commands I use to configure the red ethernet port as a DHCP client WAN port. All commands are issued via the console using SSH (dropbear) or the hard wired serial connection.

  1. Create and assign the WAN port to VLAN 2...
uci set network.@switch_vlan[0].ports='0 1 2 4 6t'

uci set network.@switch_vlan[1]=switch_vlan
uci set network.@switch_vlan[1].device='switch0'
uci set network.@switch_vlan[1].vlan='2'
uci set network.@switch_vlan[1].ports='5 6t'
uci set network.@switch_vlan[1].vid='2'
uci commit network
  1. Add the "wanred" interface...
uci set network.wanred=interface
uci set network.wanred.proto="dhcp"
uci set network.wanred.type="bridge"
uci set network.wanred._orig_ifname="eth0.2"
uci set network.wanred._orig_bridge="true"
uci set network.wanred.ifname="eth0.1 eth0.2"
uci set network.wanred.hostname='RedHotWan'
uci commit network
  1. Link the wanred interface with the WAN firewall ruleset...
uci set firewall.@zone[1].network="wan wan6 wanred"
uci commit firewall

The/etc/config/network file should then contain these entries...

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'
        option vid '2'

config interface 'wanred'
        option proto 'dhcp'
        option type 'bridge'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'true'
        option ifname 'eth0.1 eth0.2'
        option hostname 'HH5A'
        option auto '0'

Also you can make the 'B'roadband LED flash red with wanred traffic...

uci add system led
uci set system.@led[-1].name="RedWan-Port-Link"
uci set system.@led[-1].default="0"
uci set system.@led[-1].sysfs="bthomehubv5a:red:broadband"
uci set system.@led[-1].dev="eth0.2"
uci set system.@led[-1].trigger="netdev"
uci set system.@led[-1].mode="tx rx"
uci commit system

Thanks Geekuino

I'll work through those to ensure I understand them all. You don't happen to have the commands to revert those changes already written down though do you (so I can check my understanding).

No worries if now, I'm more concerned about the first uci commands, rather than the changes to /etc/config/network.

@beardedfool When using UCI, the safest way is to save the config files before making any changes - as there is no undo command in uci. :sunglasses:

cd /etc/config/ 
cp network network.safe
cp system system.safe

You can see the UCI commands by entering:

uci ?

Become a UCI expert: https://openwrt.org/docs/guide-user/base-system/uci

Evening all,

Just wanted to let you know I know have two up to date routers!

Now the real learning begins, sure I'll have other questions so see you around but, for now, a huge thanks for taking the time to look at this for me. Hugely appreciated

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.