BT homehub 5 slow

I have fibre to cabinet connection in an area far from the cabinet but have had consistent ~30mb/s download speeds since having this installed and using the router provided by my ISP Post Office Broadband which is now faulty with a constant rebooting issue. So I used this opportunity to get a BT homehub 5 with OpenWrt installed and upgraded to the latest version of OpenWrt available before configuring it as per the wiki for this router.
After a couple of weeks usage the download speeds have been consistently less than half of what I had been getting.
I have had a look on the forum for similar issues and have seen advice about updating the latiniq firmware from elsewhere on the net.
see Homehub 5 - Slow VDSL speed
Any advice on how to achieve this or how to improve things any other ways would be gratefully appreciated.

A few questions:

  1. How did you measure the speed (~30mbps) on HH5a?
  2. What is the guaranteed speed by your ISP?
  3. Do you have any QoS or VPN service configured on HH5a?
  4. Can you test your current line using another modem/router and see if you can get a better speed with it?

My VDSL speed dropped-off recently, too. I managed to restore my usual speeds by changing the filter. I've got an old NTE5a master socket, so bought a MK3 VDSL faceplate for it. Seemed to do the trick. Might not be your issue, but worth trying for a few quid.

  1. speedof.me and other line speed sites.
  2. unsure as I have not looked for some time. But I did complain to the ISP when my speed dropped shortly after having it installed and it did come back to ~30mb/s
  3. not much set up on the router yet apart from the connection and only testing from one laptop currently.
  4. The ISP supplied modem/router broke and I don't have another spare VDSL modem/router.

Thanks for the advice I do have a spare filter which I could try.
I have an old master socket which I was using both before and after the modem/router change.

Speedofme, for all its visual bling, is rather imprecise (typically it over-estimates the available bandwidth). I would recommend to use the "official" speedtest for your area, which I believe would be https://checker.ofcom.org.uk/broadband-test, or the official German one (breitbandmessung.de). Or if you want a non-governmemt linked test try https://www.dslreports.com/speedtest

P.S.: On the HH5a what is the output of the following command (on the router's shell)?
/etc/init.d/dsl_control status

Sorry to go of your subject but would you mind sending me your settings for the Post Office. I carnt get my home hub to work with them and couldn't find anything on the web. Thanks

What does the DSL status report on the HH5A for the 'Data Rate' and other values when you are witnessing slow speeds?

LuCI -> Status -> Overview

fwiw, I thought PostOffice use TalkTalk infrastructure.

Have a look at TalkTalk Fibre information in section 7.5 to see if it will solve your problem:
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

Talktalk page:
https://community.talktalk.co.uk/t5/Articles/Set-up-a-non-TalkTalk-router/ta-p/2205383

Update
This thread mentions how to extract PostOffice username & password for ADSL modem use:
https://forums.thinkbroadband.com/postoffice/4446336-user-name-for-modem.html?fpart=all&vc=1

But halucigenia says later in this thread that fibre is working fine with PPPoE protocol.

1 Like

dslreports shows similar download speeds

root@OpenWrt:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          Broadcom 164.140
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.7.9.9.0.6
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 323 / Far: 77806
Severely Errored Seconds (SES):           Near: 8 / Far: 18
Loss of Signal Seconds (LOSS):            Near: 2 / Far: 0
Unavailable Seconds (UAS):                Near: 122 / Far: 122
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.93 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 14.973 Mb/s / Up: 1.133 Mb/s
Line Attenuation (LATN):                  Down: 32.9 dB / Up: 12.8 dB
Signal Attenuation (SATN):                Down: 31.4 dB / Up: 12.8 dB
Noise Margin (SNR):                       Down: 5.1 dB / Up: 6.1 dB
Aggregate Transmit Power (ACTATP):        Down: 12.8 dB / Up: 10.5 dB
Max. Attainable Data Rate (ATTNDR):       Down: 15.474 Mb/s / Up: 1.133 Mb/s
Line Uptime Seconds:                      49418
Line Uptime:                              13h 43m 38s

For VDSL (FTTC):

  1. Go to LuCI → Network → Interfaces.

  2. Set 'DSL' parameters to 'Annex B(all)' and 'tone' set to 'A43C + J43 + A43', select PTM, and VDSL.

  3. Edit the 'WAN' interface → Physical Settings tab.

  4. Select 'Custom Interface' and enter 'ptm0.101' or 'dsl0.101' for LEDE 17 and OpenWrt 18 respectively to set vlan 101 for BT Openreach network compatibility.

For most ISPs except for TalkTalk and Sky/NOW broadband:

  1. Edit the 'WAN' interface.

  2. Choose PPPoE protocol.

  3. Enter username and password.

from here:-
https://openwrt.org/toh/bt/homehub_v5a

1 Like

If your property does not have a modern Openreach VDSL face plate (two sockets, one for phone, other for fibre modem), have you tried wiring the modem into the hidden engineer's test socket?

https://youtu.be/9VQNJGhUNHM

see output of /etc/init.d/dsl_control status above

My connection works with 'Choose PPPoE' protocol as per above, do you think that it should be 'Choose DHCP protocol' as per the link https://openwrt.org/toh/bt/homehub_v5a instead?

No, I have not tried hidden engineer's test socket but the cabling is identical to when I was getting faster speeds with the other modem/router with only a few days in between the old one going down and the new one being connected.

Use of PPPoE or DHCP won't make a difference to the line data rate which is currently around 15 mbps.

Data Rate: Down: 14.973 Mb/s / Up: 1.133 Mb/s
Line Attenuation (LATN): Down: 32.9 dB / Up: 12.8 dB
Signal Attenuation (SATN): Down: 31.4 dB / Up: 12.8 dB
Noise Margin (SNR): Down: 5.1 dB / Up: 6.1 dB

If you are able to log into Postoffice broadband with PPPoE using PO username & password, then I must be wrong about Post Office using similar settings to TalkTalk.

It looks like a line fault at first glance to me. You must be on a very long line too. Try the test socket in first instance, especially if your property has old telephone extension wiring.

When you said the Post office modem was rebooting, was it actually losing broadband connection frequently, rather than shutting down and restarting?

2 Likes

Looking at the DSL status output, it seems to me that the problem is not with your HH5a device, but with the bandwidth allowed by your provider. You can see that your actual data rate is almost the same as your Max. Attainable Data Rate, and both are lower than you expect. This makes me wonder, does your provider really provides you with a high-speed VDSL service, or is it a sort of ADSL which is somehow disguised to look more expensive?

In any case, this is something I would raise (repeatedly) with my ISP.

1 Like

it was actually shutting down and restarting.

OK, I will raise it with my ISP and see what they say.

I think the speed issue could be related to being far away from the cabinet. As the status values show there's no difference in maximum and actual speeds. This indicates that whatever signal the router is getting seems bad for a VDSL connection.

It can also be because of some faulty wiring between the router and the wires coming to your home, maybe faulty internal wiring. I'd first check my internal wiring possibly through a multimeter to see if the wiring doesn't have any issues. After removing any ambiguity here I'd move to my ISP to see what they say about it.

Please take this into consideration that Broadcom based ADSL /VDSL modems have better usability in some situations than Lantiq ones. This is because of the lack of proper driver support for Lantiq based routers.