Bt home hub 5a talktalk adsl setup help needed

I have flashed a bt home hub 5a that a friend has given me but i am unable to connect to the internet. I have read and followed a few posts on this forum but i am unable to get my talktalk connection working. what setting do i need to change ? These are the setting i found on the talktalk website.

VPI: 0
VCI: 38
MTU: 1432
DNS settings: Set as automatic (or similar)
Encapsulation: PPP over ATM (PPPoA) using VC-MUX
Modulation Type: Auto

Thanks Nikki

I have managed to get it to connect to talktalk but i still do not have a internet connection I am totally lost now I am unsure what to try next.

thanks Nikki

Your ADSL connection itself is working but we've not enough information yet to see if the subsequent PPP connection (over the ADSL connection) done by the pppd daemon is working. On the Status page, does the IPv4 WAN Status show populated details and connectivity?

If not, then just first double check you have entered your username "" and password correctly. Then look at the System Log and search for "pppd" to see if there is any authentication or connection errors.

thank ill check it and report back shortly

I have checked all my settings but i dont see anything wrong.

Interface overview :

my system log :

my network settings:

Thanks Nikki

Mmmh, you might want to try PPPoE instead, as far as I know many british ISPs will automatically switch between PPPoA and PPoE depending on what the customer sends. Now, PPPoA might be preferable in your situation (typically less overhead than PPPoE), but for testing PPPoE might be a decent choice. Make sure to edit /etc/ppp/options, so that it contains at least the following entires:
logfile /tmp/MyPPPLog.txt

That way you do not need to weed through logread, but should get a decent log in one place (heck, this might even work for PPPoA, but I have never tried that myself due to lack of opportunity). Maybe you can post the output of that?

Best Regards

I had to do a bit of work before it would connect to Sky too.

Not sure v43 should be on.

I gather the username and password is right. Are you using windows?

Yes I am using windows I tried lots of different settings last night with out any luck

thanks nikki

Can you try deleting the ATM Bridge? It's not needed for ADSL with PPPoA but is created by default on DSL devices by OpenWRT/LEDE and is probably causing pppd to report the "No such device" error. I've had to delete it for my similar Lantiq XRX200 based TP-Link W8970.

Also change your wan6 interface to use "@wan" instead of "pppoe-wan".

Your current DSL tone, annex and encapsulation settings are fine while PPPoA is much preferable to PPPoE for ADSL connections here in the UK.

yea you shouldn't need any extra bridges.

Try setting wan6 as a DHCP v6 Client.

If you need further help, i can try RDP if you need.

Thank You for all your help it is now working. I deleted the ATM bridge changed wan 6 to @wan and it connected right away ! It still wont connect with pppoa but it is working with pppoe.

Thanks Nikki

I have just run in to a slight problem. I have rebooted an now it will no longer connect :confused:

Pastebin your current system log and network settings again! :smile:

I have managed to get it backup and running I downgraded to 17.01.1 and set it up from fresh and its now fine. the only thing i changed before rebooting was the led setup I enabled the broadband led.

Thanks Nikki