BT Home Hub 5A Recover LEDE v17.01.4

You're not listening...the nc command is used to "copy" the firmware to the router.

The WinSCP screenshot you posted shows you have already done that...

The next command you should run is in the OpenWRT instructions settings section "install firmware with current settings". Scroll down to that location on the page.

sysupgrade /tmp/the firmware name you used

If you have ssh access and putty, just use pscp (from the same source as putty itself) instead.

The firmware is already in /tmp.

I ran

root@(none):~# sysupgrade /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-
Image metadata not found
Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check 'fwtool_check_image' failed.

So the ran

root@(none):~# sysupgrade -F /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squash
Image metadata not found
Image check 'fwtool_check_image' failed but --force given - will update anyway!
Saving config files...
killall: watchdog: no process killed
Failed to connect to ubus

Enter the following commands in the router command line - one at a time...

ubus listen &

ubus call network.interface.wan down

ubus call network.interface.wan up

okay cheers


So when you got the "failed to connect to ubus" message when using sysupgrade -F , did you kill the sysupgrade, or did it die on its own?

I would have expected to see something like...

Failed to connect to ubus
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

The sysupgrade -F die on it's own.

To simply things, use WinSCP to rename the LEDE firmware in /tmp to a shorter name like newfrm.bin

I would try the sysupgrade -F again (using newfrm.bin as the filename) and wait several may take a while to get to the next step.

Your last option may be to do a serial connection to flash the firmware.

okay I will do the rename of the file and just wait. I will keep you posted and thanks for all the help.


It's not going to work, since the cursor is back at the command line.

You will probably want to read this OpenWRT article on serial recovery for the BT HH 5A...

Good luck!

I have just cracked the case off and the soldering job looks at bit on the difficult side for me. Can I not use the USB port on the back too flash the router again?

No, the USB port isn't usable for that task (you may be able to avoid flashing over the serial console, given that u-boot should still be fine to use tftpboot - are there better recovery methods for uboot-lantiq without needing a serial connection?). But given that you can enter failsafe mode, I really don't understand why softreset and/ or flashing from failsafe mode don't work for you.

What happens if you go back to step 1.

  • power off the router
  • access failsafe mode
  • execute the "firstboot" binary and say yes to deleting the overlay
  • reboot -f

Given your explanation, that should already unbrick your device.

fwiw, I notice in your original screen shot, when you executed 'firstboot' in failsafe mode, you entered upper case 'Y' instead of lower case 'y' when prompted.

ie. firstboot perhaps did not execute.


Is this you?

@bill888 You are correct I typed Y instead of y in the firstboot command prompt.

Router is up and running know.

@bill888 @jwoods @slh Thanks for all the help guys.

No that's not my post.

Just curious - have you tried hard resetting the router by pressing and holding the red Reset button for 30+ seconds? This should've execute the same commands as the soft reset which is a bit error-prone as we see.

No I didn't give that a go.