BT Home Hub 5A once a day LAN ports are completely off

Few weeks ago I switched from version 22.03.6 to 23.05.3 and all was working fine until this Monday, when all my devices connected to LAN ports goes completely off. Yesterday I had this same situation, and today as well. Devices connected to wifi are working, but connected to LAN not.

There is completely no errors in syslog or kernel log files what can point me to anything. I was checking if this could be bridge issue related to changing ports state from forwarding to blocking, but no, all used LAN ports are in forwarding state.

I can't do much except to reboot router, and this are resolving issue.
I'm thinking to do router configuration wipe, and configure it again (a lot of things to configure) or if this will not help, I will try to back to previous system 22.03.6.

Is there anything what could be done, to try to figure out what causing this issue ?

Does restoring a configuration from a backup restore the factory settings before applying the configuration from the backup?

Are you willing to share the configs before wiping the device?

Which config file particular ?

/etc/config/network

/etc/config/dhcp

/etc/config/wireless


Can someone post the pre canned text that provides instructions to obtain configs.

@psherman maybe?

I can't seem to locate it.

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option htmode 'VHT80'
	option country 'GB'
	option cell_density '0'
	option disabled '1'


config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:0e.0'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key ''
	option ssid ''
	option ft_over_ds '1'
	option encryption 'psk2+ccmp'
	option nasid 'D05794B0A4AC'
	option mobility_domain '3d47'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option reassociation_deadline '1000'
	option disassoc_low_ack '0'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option cachesize '0'
	option rebind_protection '1'
	option strictorder '1'
	option quietdhcp '1'
	option boguspriv '0'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option sequential_ip '1'
	option filter_aaaa '1'
	option dnsseccheckunsigned '0'

config dhcp 'lan'
	option interface 'lan'
	option limit '150'
	option leasetime '12h'
	option ra 'server'
	option ra_management '1'
	option start '100'
	option dns_service '0'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '3'

/etc/config/wireless

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd96:c31f:4726::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option line_mode 'vdsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option ds_snr_offset '0'

config interface 'lan'
	option proto 'static'
	option ip6assign '60'
	list ipaddr '192.168.1.254/24'
	option delegate '0'
	option device 'br-lan'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd0:57:94:b0:a4:aa'

config interface 'wan'
	option proto 'pppoe'
	option password ''
	option service ''
	option username ''
	option mtu '1492'
	option ipv6 '0'
	option delegate '0'
	option peerdns '0'
	list dns '208.67.222.222'
	list dns '208.67.220.220'
	option device 'dsl0.101'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'd0:57:94:b0:a4:ab'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option delegate '0'
	option auto '0'
	option reqaddress 'none'
	option device '@wan'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'eth0'