BT Home Hub 5A bugs?

I just loaded 19.07.0-rc2 onto a BT Home Hub 5A and I've run into some issues, so I'd like to know if the following is normal as I'm new to OpenWrt.

  1. The transmit power for radio 1 (AR9287 - 2.4GHz) defaults to 18dBm and although it offers 19dBm and 20dBm they won't apply. It'll only use 20dBm if I change the country code to the US, despite 100mW being the maximum across Europe. Is this a bug?

  2. You're supposed to set custom DNS on the WAN, right? But if I configure it to use Googles DNS then some addresses resolve to TalkTalk (my ISP) when they shouldn't.

For example, if I go to network > diagnostics and use NS lookup on "img-prod-cms-rt-microsoft-com.akamaized.net" I'd get this...

Name: img-prod-cms-rt-microsoft-com.akamaized_dot_net
img-prod-cms-rt-microsoft-com.akamaized_dot_net canonical name = a1449.dscg2.akamai_dot_net
Name: a1449.dscg2.akamai_dot_net
Address 1: 62.24.203.40
Address 2: 62.24.203.43
img-prod-cms-rt-microsoft-com.akamaized_dot_net canonical name = a1449.dscg2.akamai_dot_net
Address 3: 2001:7e0:2:305::3e18:cb2b
Address 4: 2001:7e0:2:305::3e18:cb28

But if I configure the WAN to use Cloudflares DNS then it'll resolve correctly.

Name: img-prod-cms-rt-microsoft-com.akamaized_dot_net
img-prod-cms-rt-microsoft-com.akamaized_dot_net canonical name = a1449.dscg2.akamai_dot_net
Name: a1449.dscg2.akamai_dot_net
Address 1: 2.21.75.18
Address 2: 2.21.75.42
img-prod-cms-rt-microsoft-com.akamaized_dot_net canonical name = a1449.dscg2.akamai_dot_net
Address 3: 2001:7e0:2:305::3e18:cb2b
Address 4: 2001:7e0:2:305::3e18:cb28

If I use an Openreach VDSL modem with an old Billion router then both Googles DNS and Cloudflares DNS work perfectly. So I can only assume that this is a bug too?

For a connection with TalkTalk the WAN is configured as a DHCP client, if that matters at all.

Issue #1 looks to be identical to this bug, which is more than a year old.

Issue #1 I can't comment on.

...akamized.net (along with many other large Internet services' DNS names) will likely give a different IP address to optimize expected connectivity as well as load balance. There is no single, "right" answer

Local server going to the DNS root

$ drill img-prod-cms-rt-microsoft-com.akamaized.net
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 8981
;; flags: qr rd ra ; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; img-prod-cms-rt-microsoft-com.akamaized.net.	IN	A

;; ANSWER SECTION:
img-prod-cms-rt-microsoft-com.akamaized.net.	300	IN	CNAME	a1449.dscg2.akamai.net.
a1449.dscg2.akamai.net.	20	IN	A	23.197.50.17
a1449.dscg2.akamai.net.	20	IN	A	23.197.50.41

Cloudflare

$ drill @1.1.1.1 img-prod-cms-rt-microsoft-com.akamaized.net
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 46506
;; flags: qr rd ra ; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; img-prod-cms-rt-microsoft-com.akamaized.net.	IN	A

;; ANSWER SECTION:
img-prod-cms-rt-microsoft-com.akamaized.net.	218	IN	CNAME	a1449.dscg2.akamai.net.
a1449.dscg2.akamai.net.	16	IN	A	104.123.71.144
a1449.dscg2.akamai.net.	16	IN	A	104.123.71.163

DNS over TLS (round robin)

$ drill img-prod-cms-rt-microsoft-com.akamaized.net
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 31829
;; flags: qr rd ra ; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; img-prod-cms-rt-microsoft-com.akamaized.net.	IN	A

;; ANSWER SECTION:
img-prod-cms-rt-microsoft-com.akamaized.net.	299	IN	CNAME	a1449.dscg2.akamai.net.
a1449.dscg2.akamai.net.	20	IN	A	92.122.94.80
a1449.dscg2.akamai.net.	20	IN	A	92.122.94.88

That I understand, but Googles DNS shouldn't ever resolve it to my ISP (TalkTalk). It should always resolve to Akamai Technologies.

TalkTalk are one of the UK ISPs that are known for DNS hijacking, but I've already opted out of that. Plus lets keep in mind that I've already tested this from another router, which gets the correct results with both Googles DNS and Cloudflares DNS.

Unless I am mistaken, I don't think it is possible to manually set DNS for WAN interface when configured as DHCP client. I think setting DNS in LAN interface should solve your problem.

Check LuCI -> Status -> Overview -> Network to confirm what DNS servers are in use on the WAN interface.

I should of mentioned that I'd checked there, just to make sure I wasn't going crazy. It'll list the custom DNS correctly and dnsleaktest.com confirms when I'm using either Google or Cloudflare.

If I add Googles DNS to the LAN and flush the DNS cache then a few address will start resolving to TalkTalk again.

I simply can't wrap my head around why Clouldflares DNS would get the correct results and Googles wouldn't, yet when I switch to a different router they both resolve to Akamai Technologies.

I also noticed the "current power" on 2.4ghz doesn't go over 18dbm since installing RC1 on my BT hub5A, despite having set the maximum transmit power to 20. (I normally have it set to max to discourage the 5 APs of my two nearest neighbours, which seem to be all set to automatic channel selection, from switching to the same channel as mine.)

iwinfo reports: Tx-Power: 18 dBm

Just tried switching country to US and it does indeed go back to 20dbm.

I had wrongly assumed adding custom DNS servers to the LAN would stop my ISP provided slow DNS being used, but I see from that test that my preferred DNS was only used once, which probably explains why I didn't notice any improvement in performance. :slight_smile:

Setting them on WAN works fine for me on RC1, have you set them on the WAN6 interface too?

I guess someone should report the bug then? I did comment on the bug report for the AR9223, although that report seems to be buried and we've got a different chip.

I've tried that and unfortunately it doesn't help. I've even tried resetting hub and removing the WAN6 interface, but somehow TalkTalk addresses keep showing up.

I'm happy to use Cloudflares DNS, but it obviously isn't normal that I can't use Googles DNS with the HH5A.

  • What was the previous version of OpenWrt installed?
  • Do you happen to know the gain of the antennas included by the OEM?

(I'd bet it's ~ 5dBi.)

No idea, they are PCB traces and antenna gain is not marked. Is there a way to query it from the wifi calibration data?

Previous versions were the 18.06 stable on one and an earlier 19.07 snapshot from the release branch, but I can't be 100% sure if the second one was still using 20DBm or not.

I did read a post somewhere suggesting that the TX power is limited in 19.07 to take account of antenna gain, and wasn't in previous versions, which is why I didn't bother to raise it as an issue myself, but if that is indeed the case, it would seem odd to me that the same limit would not apply on changing the country to US?

I also notice the my router is now often not the strongest wifi signal of all the APs on the same channel, despite being the nearest, at only 4 foot away from me.

As far as I'm aware, TX power on 2.4 GHz radio has always maxed out at 18dBm.

Here is image from HH5A with 17.01.6 after setting 20dBm setting:

Image from same router after 'upgrade' to 18.06.4 and keeping same settings:

iwinfo confirms 18dBm too.

(HH5A is only intended for use in UK. This may be why changing the country code makes no difference to TX power. I could be wrong)

1 Like

I'm surprised that nobody has picked up on this if it dates as far back as 17.01.6.

20 dBm (100 mW) is the maximum allowed in the UK and across most of Europe, so it should work on the HH5A.

Changing the country to US is currently the only way to get 19 dBm and 20 dBm working.

Just did a bit of googling:

And it seems the maximum power in the UK is 100 mW e.i.r.p., which takes antenna gain into account, whereas the maximum power in the US is 100 mW to the antenna, and would not take into account the gain from BT hub's antenna.

So it would seem Openwrt is correctly limiting max power in the UK.

2 Likes

You can switch to TW (Taiwan) and that gives you channels 1-13, not just 1-11 and the extra power.

Changing the regulatory domain to something other than your location is, in most jurisdictions, illegal.

Is there a reason why the 5GHz radio does default to 20 dBm (100 mW) when the country is set to GB then? The antennas (PCB traces) are the same for both radios.

If 2.4GHz is being limited due to antenna gain then surely LuCI should remove the values that we can't actually use? And the text should probably mention that antenna gain is a factor.

Ideally someone with more knowledge should be able to look at the code to see exactly what's going on.

I do know the regulations for 5ghz are different, presumably due to range and penetration through walls, I think there are also different limits on each of the UK's 5ghz bands and restrictions on outdoor use.

A quick google found this:- https://www.cablefree.net/wirelesstechnology/unlicensed-wireless-links/using-the-5ghz-band-in-the-uk/

rc1, which I'm still using, does have a note that the actual transmit power may be reduced by the driver, depending on regulatory limits, but I agree that it might be a good idea, if it is practical to do so, for the UI to only offer up to the max value you can legally use, and I think it might be helpful if it showed the power including the expected antenna gain ( EIRP ) in addition to the info it shows now, however I don't have the time (or inclination) to get back into programming.