BT HOME HUB 5 TYPE A country settings do not change

i have bt home hub 5 type a
I tried every method but iw reg set US command and uci commands do not change the country. what could be the problem

Probably no problem. Usually the country is hard coded in the hardware at factory so it can’t be changed.

is there any way to change this?

If it is hardcoded in chip, probably not.

But why change it? If you don’t live in GB, where have you got the device from since it is obviously only supposed to be sold in GB?

I want to deactivate dfs channels and set country settings to india

  • :warning: Only try to set your proper country
  • You must set the same country for both 2.4 and 5.4 GHz - trying to mix will cause problems (e.g. your log may display your WiFi keeps switching nations)

You don't show them.

# in /etc/config/wireless
config wifi-device 'radioX'     
        option country 'XX'

none of these worked. country looks GB

When you have a locked device you can set what ever country you want since it doesn’t matter anyway.

1 Like

Correct, but since the OP noted US, IN and GB - I wanted to eliminate that as an issue (i.e. threads on users attempting to set multiple countries).

So, unless I misunderstand - how did the OP set GB on an IN-locked device?

Well when I bought the EU EAP225 v4 it’s wifi chip is hard locked to US and I could set whatever country I wanted in software and nothing happened. It is still US.

1 Like

I think replace wireless-regdb GB values might fix that . But You will need compile it

country GB:
	(2402 - 2482 @ 40), (20)
	(5150 - 5250 @ 80), (30)
	(5250 - 5350 @ 80), (24)
	(5470 - 5725 @ 160), (24)
	(5725 - 5875 @ 80), (30)