BT HH5a USB Storage Setup

I have just installed LEDE Reboot 17.01.0-rc2 on my BT Home Hub 5a and everything is working perfectly, including OpenVPN which I'd struggled with with the snapshots.

I've been following this guide,, for setting up a USB thumb drive connected to the router but without success. The drive is formatted as f2fs as suggested, but when I run dmesg after plugging the drive into my router I get the following

6446.362281] usb 1-1: new high-speed USB device number 6 using dwc2

Which is nothing like the output suggested in the guide. I have installed the file system drivers, kmod-fs-f2fs and these kernel modules are also installed, kmod-usb-core, kmod-usb-dwc2 and kmod-usb2. The guide makes no mention of dwc2, and I'm not sure what this is.

I have tried installing, uninstalling the modules listed under the legacy information section of the guide, but nothing seems to help.

If anybody has managed to get USB drive support working on their home hub I'd be interested to know how you did it! The drive I am using is a USB thumb drive, that I used to use on my TP-Link router using OpenWRT, I've just reformatted it.

Not sure if this applies to your situation but I missed to install kmod-usb-storage & block-mount.

thanks Doppel-D, I don't have those installed and they are not mentioned at all in the lede-project storage guide! I'll install these and report back.

Ok, installed the suggested packages & everything now works perfectly. Edited the lede-project document on storage to suit.

Thanks :grinning:

1 Like