BT HH5 USB connection

I have recently converted an old HH5 to OpenWRT, and have now flashed the latest stable version 19.07.02. I wanted to check the nand backup so I need the USB port to work. I was surprised that it doesn't work by default and followed this guide:
This was mostly OK but the format of the USB didn't find it, and neither does it mount.
This is the kernel log - last few lines.

2859.915919] usb-storage 1-1:1.0: USB Mass Storage device detected
[ 2859.922085] scsi host0: usb-storage 1-1:1.0
[ 2860.932071] scsi 0:0:0:0: Direct-Access     Generic  STORAGE DEVICE   1532 PQ: 0 ANSI: 6
[ 2861.518935] sd 0:0:0:0: [sda] 7774208 512-byte logical blocks: (3.98 GB/3.71 GiB)
[ 2861.525983] sd 0:0:0:0: [sda] Write Protect is off
[ 2861.529913] sd 0:0:0:0: [sda] Mode Sense: 21 00 00 00
[ 2861.535815] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[ 2861.552460]  sda: sda1
[ 2861.561073] sd 0:0:0:0: [sda] Attached SCSI removable disk

This is the status:

root@OpenWrt:/# ls -al /dev/sd*
brw-------    1 root     root        8,   0 May  6 13:51 /dev/sda
brw-------    1 root     root        8,   1 May  6 13:51 /dev/sda1

Manually mounting doesn't work either.
I have tried various USB sticks and also different flash options.
Any ideas, as I wasn't expecting a big problem as it worked OK for the initial install.

What's the file system? Did you install support for that file system?


Tell us the exact command you are using to mount it manually, and the result message.

1 Like

I hadn't realised that the FAT32 fs system wasn't added by default, so adding it solved the problem.
Thanks for all the help

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.