BSS Max Idle Period element is not present in the association response frame even thought the WNM sleep_mode capabiltiy is 1

Below are the configurations made on the AP with the open wrt.

wireless.wifi1.hwmode='11g'
wireless.wifi1.htmode='HT20'
wireless.wifi1.channel='3'
wireless.@wifi-iface[1]=wifi-iface
wireless.@wifi-iface[1].device='wifi1'
wireless.@wifi-iface[1].network='lan'
wireless.@wifi-iface[1].mode='ap'
wireless.@wifi-iface[1].encryption='none'
wireless.@wifi-iface[1].ssid='xs_pine6'
wireless.@wifi-iface[1].channel='3'
wireless.@wifi-iface[1].wnm_sleep_mode='1'
wireless.@wifi-iface[1].ieee80211v='1'
wireless.@wifi-iface[1].ieee80211k='1'
wireless.@wifi-iface[1].bss_transition='0'
wireless.@wifi-iface[1].ieee80211r='0'

Is there any other configuration that needs to be done to enable the wnm so that in the association response frame BSS max idle period will be present which is vital for the whole wnm sleep?
According to the IEEE Std 802.11™-2016 (Revision of IEEE Std 802.11-2012)


if "dot11WirelessManagementImplemented " is true the BSS Max Idle Period element should be present in the association response .
Does anyone have any idea how to make sure this flag "dot11WirelessManagementImplemented " is true?

What makes you think the parameter is missing?
It is there and you can adjust it using the max_inactivity option.

This :point_down: corresponds to a value of 600 (1000 TUs ≈ 1.024 seconds)

image

1 Like