Brother printer/scanner: Get scanner working

The post you mention is just SPAM, there is no info there about your issue.

1 Like

I agree, there is no info in the post but the user said

He seems to have a solution and I'd like to ask to him.

You will not get any usable answer from a spammer, since his only motivation to post in forums is to spam. He certainly never had any of the problems mentioned in this topic.

1 Like

Spammers use social engineering to get your attention and convince you to click on the link.

1 Like

Ok I understand. I didn't click the link, I suppose it was as you wrote.
Sorry for my ignorance.

Hey, I know it's been a while but did you manage to setup your scanner?

I purchased an Archer C7 v5 router and a printer/scanner combo, a Brother DCP-1602 laser printer. I've flubbed around a bit trying to find a proper SANE driver for it or to configure SANE over the network but was unsucessful. I did manage to get it working over the lan with usbip and with the 17.01 libudev package using the command: "opkg install --force-downgrade libudev_3.2-1_mips_24kc.ipk", without quotes. There was no problem in the official Brothers linux scanners drivers installation and utilization with a linux machine but there's no official usbip support in windows!

The only available solution is the unofficial usbip for windows however it doesn't have an official driver certificate, requiring test signing to be turned on...

Did you find a more agreeable solution?


Hi T4V0,
This is an old thread but is still in the agenda. I had not time to go further.
As I understand you found a way. Maybe the bug in libudev was the issue.
Thank you to let me know, I'll be back in few days to let you know if it's working.

Hi, just letting you know there's an alternative to usbip that works with windows, virtualhere usb server, its trial version only works with one device at a time but it's compiled to a few CPUs architecture (i386, AMD64, ARM, ARM64, MIPS and MIPSEL), I'll use it until there's a official usbip version for windows.

I don't know why this post was marked as spam, I just suggested an alternative to usbip on windows since there's no free one available, if there's another similar free program compatible with windows I would like to hear it. I searched other usb over the internet programs and this one is the only one that offered a trial version without a time limit, and I'm not being paid to suggest it, I wanted to use only usbip but, to reiterate, choosing between the uncertificated usbip-win, that requires windows to be in test mode, or a certificated program in trial version, I preffer the latter.

Hi T4V0,
As you are experienced in scanner install, could you advise about usbip package install, 6 are in the repo:
Which ones are necessary to run the scanner?
BTW, I run Linux Opensuse 15.2 on my desktop

You need the usbip-server package for the router, it should automatically install the packages usbip, kmod-usbip and kmod-usbip-server since they are its dependencies. Don't forget you need to downgrade your libudev package with the older package built for your router's architecture, I recommend restarting the router after the installation.

And for your desktop, you need to install the official linux driver for your printer, in the Brother's driver website there's a .rpm package, which is the supported package type for your distro. You also might need to install a SANE frontend, I use simple-scan.

Hard time for me.
I tried to install the previous version of libudev

opkg update
opkg install --force-downgrade libudev_3.2-1_arm_cortex-a9_vfpv3.ipk
Collected errors:
 * wfopen: libudev_3.2-1_arm_cortex-a9_vfpv3.ipk: No such file or directory.
 * pkg_init_from_file: Failed to extract control file from libudev_3.2-1_arm_cortex-a9_vfpv3.ipk.

I removed the installed version

opkg remove --force-depends libudev-fbsd

and tried again but again same error.
I downloaded it and tried with the GUI

Executing package manager

Installing libudev-fbsd (20171216-1) to root...


Collected errors:
 * check_conflicts_for: The following packages conflict with libudev-fbsd:
 * check_conflicts_for: 	libudev * 
 * opkg_install_cmd: Cannot install package libudev.

The opkg install command failed with code 255.

Any help?

Did you download the package and transfer it to your router?

From your desktop's terminal:


Then transferring to the router:

scp libudev_3.2-1_arm_cortex-a9_vfpv3.ipk root@openwrt:/root/

And then, after entering your router's shell:

opkg --force-depends remove libudev-fbsd

opkg --force-downgrade install libudev_3.2-1_arm_cortex-a9_vfpv3.ipk

And restart.

I did it with the command line from the repo, from GUI local (separately downloaded) and again following your commands. Same error!?

Can you paste here the error message?

And the output of the command:

opkg info libudev

I did a reboot, still the same

~# opkg info libudev

~# opkg --force-downgrade install libudev_3.2-1_arm_cortex-a9_vfpv3.ipk
Installing libudev-fbsd (20171216-1) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with libudev-fbsd:
 * check_conflicts_for: 	libudev * 
 * opkg_install_cmd: Cannot install package libudev.

opkg info libudev => No answer
libudev is not installed



installed might need to resolve conflict with that first.

Reinstalled libudev-fbsd

 opkg list-installed libudev-fbsd
libudev-fbsd - 20171216-1

~# ls

Previous version is in root directory

~# opkg --force-downgrade install libudev_3.2-1_arm_cortex-a9_vfpv3.ipk
Package libudev-fbsd is already installed on root.

With the GUI, try to install offline: Click upload package, Browse

Manually install package

Installing packages from untrusted sources is a potential security risk! Really attempt to install libudev_3.2-1_arm_cortex-a9_vfpv3.ipk?

    Size: 52.41 KB
    MD5: 3877ed36c31d2003d64186d5895b9a6f
    SHA256: 3757e2ebc99e5d25703173e170207db1f180cbd6547f103d2fb6ac35c93e187a

Click Install

Executing package manager

Package libudev-fbsd is already installed on root.

Are you installing the same version ?

Not at all
In OpenWrt 19.07.3, libudev-fbsd is v20171216-1, size 5.8 KB installed
see here
libudev-fbsd_20171216-1_arm_cortex-a9_vfpv3.ipk 5.7 KB Sun Apr 19 09:55:59 2020

In OpenWRT v17.01.6, libudev_3.2-1_arm_cortex-a9_vfpv3.ipk 52.4 KB Sun Jul 22 11:23:17 2018
See here
This is this last version I have downloaded in the router at /root and in my PC


This is weird. What happens if you run the command:

opkg --force-reinstall install libudev_3.2-1_arm_cortex-a9_vfpv3.ipk
1 Like