Broken fw image cant go back to the working fw

Hey, I have a Strong 1200 Router and flashed OpenWrt 8 months ago onto it, worked fine until now. I wanted to install a package for it but it refused because one kernel was not up to date and updating it didn't work.

So I reflashed the Router with what I hoped were newer Snapshots with the uptodate kernel. Now the Web Panel is broken and I cant upload the old firmware I saved localy which worked fine.

Are there any other ways to upload the old working firmwares?

Snapshot builds do not include LuCI web interface. You can log into the device with ssh and install luci from there.

opkg update
opkg install luci
2 Likes

For many devices supported by OpenWrt, firmware were made by concatenating kernel and rootfs together then split at boot time. This is mainly for saving space. And it means for most of the time a firmware upgrade is needed to upgrade the kernel.

I am wondering which package you are trying to install. Is it possible that it refuses merely because the package and kernel are from different builds?

1 Like

If you install a snapshot, LUCI is not included as already said.
In general, kernel modules must match the kernel, which is included in the firmware image.
Moreover, snapshots (including kernel modules) change all the time, so the only ways to ensure you always have the matching modules for your installation are:

  • downloading the whole tree for your device (good approach if you don't track snapshots)
  • setting up the build system on your PC (a bit more effort at the beginning, saves time in the long run if tracking)
1 Like

Thanks for the reply, i looged in with ssh and sucessfully installed opkg update, but it refuses to install opkg install luci

root@OpenWrt:~# opkg install luci
Installing luci (git-19.231.47191-2aab858-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
 * opkg_install_cmd: Cannot install package luci.

As far as i know, my router has 16mb of onboard storage which was mostly free.

Check that there is free space available, with "df".
This is my router now, for example:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2816      2816         0 100% /rom
tmpfs                   125436      1476    123960   1% /tmp
/dev/mtdblock14          24192      5556     18636  23% /overlay <--- THIS
overlayfs:/overlay       24192      5556     18636  23% /
tmpfs                      512         0       512   0% /dev
1 Like
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                    61488       776     60712   1% /tmp
tmpfs                      512         0       512   0% /dev

Now that's interesting! :slight_smile:

Your device is missing overlay altogether. Forget about installing new software: if you make any changes to the configuration, do they survive reboot? I'd say they don't.

1 Like

So what do I have to do? I dont know much about OpenWrt stuff.

For starters, answering the question - otherwise we won't know what you should do:

2 Likes

Where do I make changes and check if they survived?

...in the router. Anything.

1 Like

The Webpanel now is completly unable to access since I should do "opkg update" via ssh. Didnt reboot since then.

I got the same error when trying to install packages on a snapshot yesterday and my wrt1200 has plenty of space, so I'm assuming it's just a problem with the latest builds, you might try a stable build if possible.

1 Like

Can you give me a link to a stable build? Otherwise I have a old stable build saved locally from 8 months ago but idk how to install it without a web panel.

Wait stop...you installed a snapshot. It doesn't have a web GUI. Are you saying you need instructions on how to SSH and install it?

Otherwise, I'd take @mike's advice:

Wow...actually...No, per your hardware's page - your device is only currently available with a snapshot.

https://openwrt.org/toh/hwdata/strong/strong_1200

Just install the LuCI web GUI.

2 Likes

Thanks for the instructions. The Webpanel kinda worked, but i guess its just cached in my browser or something like that. But I linked the Video already in my first post.

I installed putty and alredy tried the first steps but I get an error when i try "opkg install luci"

It looks like your model requires the initramfs to be flashed first and I'm just not familiar with that unfortunately and don't know what needs to be done.

2 Likes
  • You wouldn't answer @aboaboit's question
  • So we figured out that it does seem you have a free file space issue!

It really would help if you'd answer questions...

Yes, likely cache cause that display. The video isn't helpful, as no web GUI access is a common symptom with many causes.

  • If you installed LuCI before then re-flashed the device, LuCI would disappear.
  • Now the file space issue is another problem that must be solved first.

To solve the file space issue try flashing your router a second time - this is known to fix that issue on most devices.

2 Likes

Using a device supported only by snapshots requires a bit of knowledge, which is best acquired outside an emergency :wink:

At this stage, if that is your only router you'll need another way to go online, while you figure out how to proceed.

2 Likes