Broken /etc/config/network after 21.02 update on WRT32X

Hello,

Can someone please help me convert my /etc/confit/network from OpenWRT 19.07 to the new syntax in OpenWRT 21.02 for my Linksys WRT32X?

I was using my WRT32X as a “dumb ap” prior to updating it. I can’t seem to figure out how to convert my network config to the new syntax…

Old OpenWRT 19.07 /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd7:ef82:7871::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.0.1'
	option ipaddr '192.168.0.176'
	option ifname 'eth0.1'
	list dns '192.168.0.118'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

Current (broken) OpenWRT 21.02 /etc/config/network

config interface 'loopback'                                                     
        option device 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                                                                                                       
                                                                                
config globals 'globals'                                                        
        option ula_prefix 'fdec:8612:60dd::/48'                                 
                                                                                
config device                                                                   
        option name 'br-lan'                                                    
        option type 'bridge'                                                    
        list ports 'lan1'                                                       
        list ports 'lan2'                                                       
        list ports 'lan3'                                                       
        list ports 'lan4'                                                       
                                                                                
config interface 'lan'                                                          
        option device 'br-lan'                                                  
        option proto 'static'                                                   
        option ipaddr '192.168.1.1'                                             
        option netmask '255.255.255.0'                                          
        option ip6assign '60'  

Every time I change

config interface 'lan'                                                          
        option device 'br-lan'                                                  
        option proto 'static'                                                   
        option ipaddr '192.168.1.1'                                             
        option netmask '255.255.255.0'                                          
        option ip6assign '60' 

It never sticks to wlan0. I have another router that manages dhcp. I want this router to accept wireless connections but not hand out IPs. I also want to use the other lan ports to connect devices and have the main router give the wired devices the IP addresses.

Can anyone help me? I feel so stupid. I wish the syntax never changed but I’m okay if I can manage to learn how to replicate the settings for a dumb AP.

The original guide I followed was here:

Thank you

For reference, my dumb AP config from WRT3200ACM:
(master, but that should make no difference, I think)

Router connected in the dumb AP way, from a LAN port wired to the main router (at 192.168.1.1). Wan is unutilised.

 OpenWrt SNAPSHOT, r17531-f413e4835e
 -----------------------------------------------------
root@router3:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd------::/48'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.3'
        option ip6ifaceid '::3'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan6'
        option device '@lan'
        option proto 'dhcpv6'
        option reqprefix 'no'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'wan'
        option macaddr '62:38:e0:bc:36:20'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

I have naturally also disabled DHCP in the WRT3200ACM.

That reference to wlan0 gets lost by me. What are you saying here?

1 Like

This is a beautiful reference point for me! I will attempt to use it.

As for the wlan0 reference, for some reason my config before allowed me to use wireless networks bridged to the interface I had. After updating I haven’t been able to get wireless working when bridged to lan — but I didn’t have a good network config so it is probably that.

Let me try this now.

I just read that this was for master router. The router I’m trying to get this to work on is connected to my main router.

Previously, I had this router (with network config issue) connected from LAN port 1 to my main router. I would connect my my dumb ap router to my master with a static IP set. I believe it was for eth0.1.

I would like the same configuration I had before, but I’m not sure how to make it work. It looks like be default lan ports 1-4 are bridged. I think I had some sort of switch setup as well. I only had eth0.1 and wlan0 bridged on a single interface in 19.07.

Hope this makes sense.

Here is the previous config through GUI:






There are no “physical settings” for interface on 21.02

Mate,

After trying your configuration and making edits to suit my network configuration, it looks like it worked.

I have a question though, for v21.02, do you still disable dnsmasq, odhcpd, and firewall? Or leave them be? I have been disabling them but I don’t want this to break.

I wish to portforward from master not have to configure my dumb ap on top of my master ap.

Thanks mate!!

Sure.
As the router is dumb, no DHCP, DNS or NAT is needed.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.