Broke my pi single arm

i goofed somthing up and broke my config, so im rocking a stock version of openwrt on the pi again,

i know to change my ip on the lan, im using 192.168.2.1 for the pi and 192.168.2.2 for the edgerouter x (vlan eth0.10 lan and vlan eth0.20 wan)

current network file is

loopback
globals

config interface 'lan'
list ports 'eth0.10'
option device 'br-lan'
option proto 'static'
option ipaddr ' 192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface ';wan'
option device 'eth0.20'
option proto 'dhcp'

config interface 'wan6'
option device 'eth0.20'
option proto 'dhcpv6'

what am i missing?

You have list ports in the config interface section. That does not work, a list of (bridged) ports needs to be in a separate bridge section-- or you can attach an interface to a single device, as wan is.

lan is usually set up as a bridge so that the (admittedly lame) Pi wifi and/or a USB ethernet port can be easily added later.
For a bridge you need to declare the bridge and its ports separately:

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth0.10'

Then the option device of interface lan is br-lan
There's also a typo in the wan name.

i manually typed it up lol. i had a previous post where i was told i didnt need the config device because im using vlan trunking to talk to the edgerouter x, but ill toss it in and see how it goes!

thank you that did it, good lord lol. i think the previous post i was using a laptop not a pi, theres a difference there i see lol

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.