Bridges not working after 21.02 upgrade

I'm running 19.07.8 on Espressobin. It has two LAN ports which are configured into a bridge (stock configuration). I have also added two more bridges on VLANs. This works well. The UCI config is:

onfig interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.42.1'
        option ip6assign '64'
        option ip6hint '42'
        option ifname 'lan0'

config interface 'iotlan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.66.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6hint '66'
        option ifname 'lan0.666 lan1'

config interface 'FILTERLAN'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6hint '44'
        option ip6assign '64'
        option ipaddr '192.168.44.1'
        option ifname 'lan0.444'

I just tried to upgrade to 21.02.0. It would not add the lan0 (no VLAN) device to the br-lan device, so the br-lan device had no interfaces. If I manually added it, then the port got blocked:

root@router:/etc/config# brctl show
bridge name	bridge id		STP enabled	interfaces
br-FILTERLAN		7fff.f0ad4e0624db	no		lan0.444
br-lan		7fff.000000000000	no
br-iotlan		7fff.f0ad4e0624db	no		lan0.666

root@router:/tmp# brctl addif br-lan lan0
[ 1010.458146] br-lan: port 1(lan0) entered blocking state
[ 1010.463596] br-lan: port 1(lan0) entered disabled state
[ 1010.490452] mv88e6085 d0032004.mdio-mii:01: p0: already a member of VLAN 1

dnsmasq was logging

Mon Oct 11 18:50:20 2021 daemon.warn dnsmasq-dhcp[4647]: DHCP packet received on lan0 which has no address

I was able to access LuCI using one of the working bridge IPs and it did some migration of the network settings which didn't help.

What's the correct way to configure this in 21.02?

I could delete all the bridges but then I don't have access to LuCI any more to reconfigure it.

You should not carry the configuration from 19.07 to 21.02, there are major differences especially the DSA on the way switch is managed.

1 Like