Bridged Static & DHCP interfaces

Hi,
I'm trying to get a few different types of hardware running LEDE to have an Always reachable static IP & also , if DHCP available , an IP on the network it is connected to .
I've tried a few approaches to this , but have not had any joy .
With the below config , the "defaultip" interface shows as having the correct ip (10.10.10.10) , but there is no response to ARP requests for 10.10.10.10 .
Can someone give me a heads up on how to achieve my goal ?
Thanks
Barry

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd75:27f7:1b94::/48'

config interface 'lan'
option type 'bridge'
option proto 'dhcp'
option ifname 'eth0 eth1 wlan0 defip'

config interface 'wan'
option ifname 'eth1'
option proto 'none'

config interface 'defaultip'
option proto 'static'
option ipaddr '10.10.10.10'
option netmask '255.255.255.0'
option ifname 'defip'

Why are you expecting an ARP reply for itself??? It knows itself.

ARP is Layer 2...physical...

Is defip a real Ethernet interface, and if so, what is it connected to???

If your LAN is set up properly, you can add option hostname 'somename' on the DHCP lan and then connect to the OpenWrt device by name.

Unlike most Linux, OpenWrt does not by default add the machine's hostname to a DHCP request. You have to configure it separately.

My PC has a number of static ip's setup.
When I connect this PC to the LEDE device only , there is no response to arp requests for IP 10.10.10.10 sent from the PC.
defip was one of my experiments to get this working ,
I tried to use that as an interface to include in the bridge .
I also tried eth0 .

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0 eth1 wlan0'

config interface 'defaultip'
	option proto 'static'
	option ipaddr '10.10.10.10'
	option netmask '255.255.255.0'
	option ifname 'eth0'

When a physical interface is in a bridge, the kernel doesn't give it an IP. It inherits any and all IP(s) that are configured on the bridge.

I'm not sure if the UCI networking system considers the possibility of an interface having more than one IP. Using the ip addr show command may reveal what is really being set up.

I'm not at the hardware currently so can't test that .
I also tried with no success

config interface 'wan'
	option ifname 'eth1'
	option proto 'none'
	
config interface 'lan'
	option proto 'dhcp'
	option ifname 'eth0'

config interface 'mybridge'
	option proto 'static'
	option ipaddr '10.10.10.10'
	option netmask '255.255.255.0'
	option ifname 'eth0 eth1 wlan0'

I did get the 10.10.10.10 ip to work when i set it up as an alias , but the alias would only work After DHCP had assigned eth0 an IP. .... not very useful !

It's called an alias in the OpenWrt wiki. Using eth0 in an interface definition doesn't make sense when eth0 is part of a bridge. You must use "br-lan", as shown in the wiki. You can't use eth0 separately and as part of a bridge at the same time.

https://wiki.openwrt.org/doc/uci/network#aliasesthe_new_way

That was the Key Mikael
option ifname 'br-lan'
I'm a happy camper now !! It works.

config interface 'wan'
	option ifname 'eth1'
	option proto 'none'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0 eth1 wlan0'

config interface lan_static
	option ifname 'br-lan'
	option proto 'static'
	option ipaddr '10.10.10.10'
	option netmask '255.255.255.0'

Many thanks everyone for helping me out here .