Bridged AP configuration

Hi experts,
First of all, sorry if I'm asking anything dumb. I'm very new to openWRT and networking in general.
I will first start by stating my need.
I have a local server running at home, were I have ZeroTier installed so I can access it remotely. Now I want to also be able to access it from a very specific device on my parents.
I'm using a TL-WR941ND, which was very hard to install ZeroTier on. I managed to build a custom image, even thought it had to be an older version of openWRT. Unfortunately I had to give up lucy to have enough space for ZeroTier.
My idea is to have my parents router connect to this TP Link one by ethernet. And then another ethernet cable from the TP to the specific device.
I've tried to setup this via the command line, just by editing /etc/config/network. I don't require wireless.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd04:8e1e:9d52::/48'

config interface 'eth'
        option ifname 'eth0'
        option proto 'none'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.4'
        option netmask '255.255.255.0'
        option gateway 192.168.1.1
        option dns 192.168.1.1

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

This gave me internet access. But everytime I reboot the router, it seems I have to enable Wifi on the device, and then turn off, to have internet via ethernet. Which makes me think I have setup something wrong, somewhere.
I have ethernet from main router connected to TP's Lan1 port. And then ethernet cable from TP's Lan2 to the device.
Also, I was able to configure zerotier, and if I perform a zerotier-cli info, it always shows as online. But if I go to zerotier central, that specific device always seem to be offline.

Any insights are really appreciated.

Thank you!

It is likely that you are out of space and thus the device is unable to save the configuration.

What is the output of

ubus call system board
df -h
mount

This begs the question: why does something you need to enable, but do not need, makes you think this is a configuration problem?

And, it raises the question: why do you want to put another hole in a wan firewall with firmware that is, by my count, 4 years outdated when ZeroTier has up-to-date and maintained software dedicated to accomplishing your goal?

It is of course much easier as a beginner to use adequate hardware so not to be fighting memory limitations.

When a VPN terminus is an "appendage" bridged into a lan, it is more complicated than setting up a second lan that uses the router running zerotier as its default route. So I would suggest leaving the 941 as a lan-wan router with its local lan having the device that you want to get site to site access.

It is important that none of the LAN IP ranges overlap-- the home lan, the remote home's lan, the 941's lan, and the zerotier tunnel all need different IP ranges.

Thanks for the suggestion. I will run those commands tomorrow as soon as I'm able and share the output

Hey,
When I say have to enable Wifi, it is from the computer, not the router. I just found that behavior weird.Not sure what the cause may be.

The device that will be connected is a LG TV, which unfortunately, doesn't support any ZeroTier dedicated software.

The only way I couldn't think of getting ZeroTier there, would be either via a raspberry or a router, I had an old one of the latter haning around, so just tried my luck.

Sometimes I'm impatient with 'Connect Automatically' after a reboot and I manually reconnect, or, if I have two radios to the same router and I want radio1 but radio0 is ready faster it looks like it is not connecting as fast as I would like to the one I want.

Totally agree with you, it was just an hardware laying around, and I didn't want to invest in something if I could get that working.
Not sure I've got your suggestion. The devices are physically apart. The server is at my house, the router with openwrt and the lg device will be at my parents.

Given the choice of a Pi that is up to date over a router that is no longer supported, I'd choose the Pi.

I do like Pis though.

I have wireless completely off on the router with openwrt.
Let me rephrase how I was testing, maybe I wasn't clear.

I've connected the main router to the one with openwrt via ethernet cable on LAN1. The one with openwrt has wireless disabled. Then I have a ethernet from LAN2 of the openwrt router into a computer (just for testing, the final scenario would be a LG TV).
When I reboot the openwrt router, I don't get internet into the computer via ethernet. I have to enable wifi on the computer, then disable it, and somehow the internet via ethernet starts working.. I'm dazzled

It will be my way to go if I can't get this working. The other downside of using Pi (a part of having to buy one), is that either I buy a double ethernet Pi, or I will have to use a normal Pi, install zerotier, and somehow then share the entire subnet of the network into zerotier. Which with a router, I could just share that into the specific device I need.

Now it makes sense.

Do the calls psherman asked for.
He can strip it bare since you are already behind a working firewall.

Sounds like a problem with the computer, not the router. Do you have another computer you can test with?

Please find below the outputs:

root@LEDE:~# ubus call system board
{
        "kernel": "4.4.61",
        "hostname": "LEDE",
        "system": "Atheros AR9132 rev 2",
        "model": "TP-Link TL-WR941N\/ND v2",
        "release": {
                "distribution": "LEDE",
                "version": "17.01.1",
                "revision": "r3316-7eb58cf109",
                "codename": "reboot",
                "target": "ar71xx\/generic",
                "description": "LEDE Reboot 17.01.1 r3316-7eb58cf109"
        }
}
root@LEDE:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    13.8M     84.0K     13.7M   1% /tmp
/dev/mtdblock3          512.0K    244.0K    268.0K  48% /overlay
overlayfs:/overlay      512.0K    244.0K    268.0K  48% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@LEDE:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

Although it turns out, it was the computer. I've been able to reboot it severtimes and always get internet by cable up and running using another laptop!

I did have some issues persisting the zerotier configs. I've followed the official guide, but this step neverworked for me:
uci add_list zerotier.my_zt_net.join=<network_id_from_zerotier_central>
It always gave an invalid argument error.
I was able to join by using
zerotier-cli join <networkid>
But this was always gone after reboots.
I was able to make the settings persist by manually editing the /etc/config/zerotier file
Then it persisted the network configuration, but everytime it rebooted, the address would change, so it would always be on REQUESTING_CONFIGURATION status..
Finally I was able to persist everything by getting the key from /var/lib/zerotier-one/identity.secret and manually add it to the configuration file.
If it helps the next person, a sample of mine is:

config zerotier 'sample_config'
        option enabled '1'
        list join 'network id'
        option secret 'replace key'

Everything seems to be working like a charm.
Can I assume as soon as I move this router to my parents, connect it to their main router, and then connect a ethernet cable to the TV, the TV will be able to reach my server at my house?

Thank you all for the inputs so far.

I don't know what happened, but the old weird behavior is back.
I have a computer connected via ethernet to LAN2 of the openwrt router. The connection is fine, if I reboot the router, I lose internet. I can still SSH into the router, and from there I can ping www.google.com, so the router itself has internet. Why does sometimes after a reboot, the connections get messy?
It requires then unplugging and plugging the cable several times to get the internet back on.
Surely I must be doing something wrong

I have moved the router to my parents. And set it up with their main router. Connected it to the TV. I can get internet just fine.
I can see the router is connected to my ZeroTier network. But the TV is not able to reach my home server.
Any suggestions? Is any extra setup needed than install zerotier into the router and join the network?

Much appreciated