Bridged AP configuration on BTHomeHub using Powerline LAN adapter

Hi there,

I am going to do the following in this intro post:

  1. explain my setup
  2. explain what I am looking to achieve
  3. what am I getting
  4. my configuration files - which ones? (sorry I am a newby)

1. My Setup:

I am using a FritzBox 7530 as the main modem and router in my house, with original firmware (i.e. I don't use OpenWRT there, as I use both DECT and modem)
I also have 2 FritzBox 3000 extenders in the house.

My end goal is to re-use two old modem-routers, ISP provided over the last 3 years, in some way. These 2 devices are "BT Home Hub 5vA, architecture xRX200 rev 1.2" -
I realised I could flash them with OpenWRT, so I did flash the first one (I forgot to download the original firmware in case so,ething went wrong - oh well, it did not, so I am now running OpenWRT).

Firmware: OpenWrt 21.02.0-rc1 r16046-59980f7aaf / LuCI openwrt-21.02 branch git-21.106.55967-06dd6b5, so I could get Luci.

2. What I want to achieve?
I initially tested in the house, connecting one of the 4 LAN (eth0.1), in a Bridged AP configuration, to a LAN port of a known IP address from one of the two repeaters I have
I could quickly connect and the Speedtest I perform under these conditions is very similar to what I get when I am connected directly to the main router or the Repeater.
Where I want to use the OpenWRT (BTHomeHub) router, utlimately, is in a room we have at the end of the garden, which is "power-wired" from the house, so I use a Tenda Powerline PH3 LAN adapter (connected to the relative transmitter connected to the FritzBox), to extend the home network to that room.

3. What am I getting
If I connect my PC over LAN directly to the LAN powerline adapter receiver in the Garden room, I also get the same Speedtest as if I was in the house, which is very good.
Hence I plugged the LAN cable from the LAN adapter receiver into one of the eth0.1 LAN ports of my OpenWRT router, using the same setup as used in the test previously done in the house. The only difference from the previous test was that I changed the SSID and Passwd to match the ones I have in the house with the FritzBox modem/router and repeaters. This way I can have a seamless experience when going from the house to the pod and back again, I would not need to change any WiFi setting (even though I appreciate this can be done automatically nowadays).

When I do a SpeedTest under this setup I am not able to match the same DL speed, as with the test done with the similar configuration (apart from SSID and PSSWD) when connecting LAN to the FritzBox repeater in the house.

DL speed with OpenWRT Bridged AP via LAN to FritzBox3000 = 62Mbps
DL speed with OpenWRT Bridged AP via LAN to Tenda Powerline LAN = between 40 and 52Mbps (very bumpy)

There is no way to get the speed to go any higher.

I was thinking about the differences in the two configurations, apart the SSID/PSSWD.
The PowerLine LAN does not have an IP address, by the look of it, whereas the FritzBox Repeater does.

Should I change the configuration file accordingly? and how if so?

4. My configuration
I am not so sure which files I was going to share here, so I am showing the config file.
If anyone is willing to help and would like to see any other files, please ask.

cat /etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '****:****:****::/48'
	option packet_steering '1'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.188.254'
	option gateway '192.168.188.1'
	list dns '192.168.188.1'
	option delegate '0'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '**:**:**:**:**:**'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '**:**:**:**:**:**'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 2 0 1'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 5'
	option vid '2'

Thanks for the attention
Giuseppe

I realised dnsmasq was running, so I shut it down:

/etc/init.d/dnsmasq stop
*[--- I thought I had done this before, but then i since had to reboot the router in a couple of occasions

  • How can I do this under luci?
  • How can this be done so dnsmasq does not come on on boot? ]*

Anyways..... I have only gained 3 to 5 Mbps after doing this --> from 50Mbps max, to 53-55Mbps.

Anything else anyone can suggest so I don't get the bumpiness in the speed?

By the way : When connecting to the LAN adapter directly via LAN cable, there is very stable connection, so I doubt the bumpiness (which I thought it was due to the Power Line connection) is only affected by the connection (100% of the times?) when I include the OpenWRT router in the middle

Go to System--Startup and click the Enabled button next to dnsmasq so it changes to Disabled. That alone will not stop it if it is running, for that either use the Stop button or reboot now that it is disabled.

Try setting back to a unique ssid so you can be sure your test rig is connected to that AP and not one of the ones inside the house. Also scan the band and choose a channel to avoid neighbors. Being outside any wifi will be subject to more interference.

Thanks for the tip over the Startup Menu in Luci.

I changed to a different SSID, still the same.

Interference is something, it seems, I need to live with, given I am in the open space.
I moved away (changed to channel 3) from some neighbours on 2.4GHz, but I could not find any interferer in the channel 36 used by the 5GHz radio.

That has made things worse, so I think I will live with the loss of 5-10Mbps when I work in the garden room. Uplink is fine.

Thanks for your help. Unless there is anything else, I will close this as solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.