Bridged AP and Print server configuration on TP-Link TL-MR3020

Question and full story below.
I have TP-Link TL-MR3020 small router with only 1 ethernet socket. By default it connected to lan side. I want it make on wan side bridged to wwan.
How to configure it?

Full story as use cases:

  1. USB printer shared via wifi. P910nd installed and wwan connected to existing wifi WLAN. I has made traffic rule from wwan to device to be PS visible on wan side and admin also.
  2. If there is no available wifi I still can connect to router and print. This type connection is on different subnet (lan side).
    Added note. Unfortunately when Wan connection is down, then also no lan wifi server working, because both are on same wifi adapter. Upgraded models can have two separate adapters for 2,4 and 5 GHz.
  3. In any case can connect to router wirelessly and reconfigure etc. because of fixed ip and wifi settings (same lan side).
  4. not yet, want to add this point. When printer have LAN port to make it wireless. I see reason to use only one available LAN port as bridged switch to wwan.
    Sound reasonably? How to achieve LAN port and printer bridged to wwan?

current network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd25:1e9e:b57a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'