Bridge wrong dhcp

Here are my network
wan: 192.168.100.xxx
IPTV (lan1): in modem it use bridge mode
openwrt: 192.168.1.xxx

I'm bridging internet (wan) and IPTV (lan1), I want to get openwrt IP (192.168.1.x) but I'm getting IPTV IP (10.70.xxx.xxx), how disable DHCP for lan1?

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'
        option delegate '0'
        option gateway '192.168.100.1'
        option force_link '0'
        option ifname 'lan1 lan2 lan3'
        option igmp_snooping '1'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option delegate '0'

config interface 'LAN_IPTV'
        option ifname 'lan1'
        option delegate '0'
        option proto 'dhcp'
        option defaultroute '0'
        option force_link '1'

If i add wan to the bridge I can't connect to internet or openwrt router

option ifname 'wan lan1 lan2 lan3'

I'm not using igmpproxy, on my Mi AC2100 it crash and force reboot.

You do not want to bridge the connections. Ideally you would configure the switch using VLANs. Post your complete /etc/config/network file.

3 Likes

When you bridge two (or more) interfaces, you just have one interface, one protocol, and one address. If you need different configuration, you do not want to bridge the interfaces.

4 Likes

vlan how? and here complete config

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fde5:e331:3c82::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'
        option delegate '0'
        option gateway '192.168.100.1'
        option force_link '0'
        option igmp_snooping '1'
        option ifname 'lan1 lan2 lan3'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option delegate '0'

config interface 'LAN_IPTV'
        option ifname 'lan1'
        option delegate '0'
        option proto 'dhcp'
        option defaultroute '0'
        option force_link '1'

config route
        option interface 'LAN_IPTV'
        option target '239.1.0.0'
        option netmask '255.255.252.0'

I still do not know what you want to achieve and why.

1 Like

Remove this from lan interface.

lan1 is part of lan and LAN_IPTV. Normally that wouldn't be a problem, but you are running dhcp server on lan and dhcp client on LAN_IPTV -> it won't work.

How are you bridging the wan with lan1 exactly?

1 Like

I want to able access internet and multicast IPTV in one cable/network, if dhcp served by lan1 then I only can watch tv with no internet.

for now to solve it, I set manually my PC IP to 192.168.1.2