Bridge/repeat multiple wifis

Hello,

I am running a devolo 1200e and want to configure it to repeat 2 wifis.
One WiFi (the guest wifi) is working perfectly, while on the other clients of the repeated network dont get an IPv4 address via DHCP.
I dont realy know, what next. I tried a lot of things, but since both bridges are configured the same, I think there is a bug somewhere.

The firewall is disabled (I dont need it there, but disabled it for debugging)
I have the same behavior (guest working, main not) with dnsmasq disabled (and an empty dhcp configuration). I also tried starting dnsmasq with dhcp-relay=192.168.11.120,192.168.11.1, but nothing seams to work.
I dont really find where the dhcp ra/dhcpv6/ndp relay config is doing anything, since it is not in the dnsmasq config, but probably digging in there would help. I think, there is probably a problem, that there are dhcp master relays on two interfaces (I tried to remove one on the *6 versions, but no difference). But on the other hand, an empty dhcp config does not change anything.

I appreciate any idea on where to dig into.

Here are my configs:
network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd75:ee6d:dd8e::/48'


config interface 'main_lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'main_wan'
        option proto 'dhcp'

config interface 'main_wan6'
        option 'ifname' '@main_wan'
        option proto 'dhcpv6'

config interface 'repeater_bridge'
        option proto 'relay'
        option network 'main_lan main_wan main_wan6'


config interface 'guest_lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'guest_wan'
        option proto 'dhcp'

config interface 'guest_wan6'
        option 'ifname' '@guest_wan'
        option proto 'dhcpv6'

config interface 'guest_repeater_bridge'
        option proto 'relay'
        option network 'guest_lan guest_wan guest_wan6'

wireless (the repeated wifis have a 2 for easier debugging)

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'DE'
        option disabled '0'

config wifi-iface 'main_ap50'
        option device 'radio0'
        option network 'main_lan'
        option encryption 'psk2'
        option mode 'ap'
        option ssid 'main2'
        option key 'mainpw'

config wifi-iface 'guest_ap50'
        option device 'radio0'
        option network 'guest_lan'
        option encryption 'psk2'
        option mode 'ap'
        option ssid 'guest2'
        option key 'guestpw'


config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option country 'DE'
        option disabled '0'

config wifi-iface 'main_client'
        option device 'radio1'
        option network 'main_wan'
        option encryption 'psk2'
        option mode 'sta'
        option ssid 'main'
        option key 'mainpw'

config wifi-iface 'main_ap24'
        option device 'radio1'
        option network 'main_lan'
        option encryption 'psk2'
        option mode 'ap'
        option ssid 'main2'
        option key 'mainpw'

config wifi-iface 'guest_ap24'
        option device 'radio1'
        option network 'guest_lan'
        option encryption 'psk2'
        option mode 'ap'
        option ssid 'guest2'
        option key 'guestpw'

config wifi-iface 'guest_client'
        option device 'radio1'
        option network 'guest_wan'
        option encryption 'psk2'
        option mode 'sta'
        option ssid 'guest'
        option key 'guestpw'

dhcp


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'


config dhcp 'guest_wan'
        option interface 'guest_wan'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option master '1'

config dhcp 'guest_wan6'
        option interface 'guest_wan6'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option master '1'

config dhcp 'guest_lan'
        option interface 'guest_lan'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option ignore '1'


config dhcp 'main_wan'
        option interface 'main_wan'
        option ra 'relay'
        option ndp 'relay'
        option dhcpv6 'relay'
        option master '1'

config dhcp 'main_wan6'
        option interface 'main_wan6'
        option ra 'relay'
        option ndp 'relay'
        option dhcpv6 'relay'
        option master '1'

config dhcp 'main_lan'
        option interface 'main_lan'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option ignore '1'

Here are some infos:
ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:XX:XX:XX brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host.
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-main_lan state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel master br-guest_lan state DOWN qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
6: br-guest_lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-guest_lan
       valid_lft forever preferred_lft forever
    inet6 fd75:ee6d:dd8e::1/60 scope global.
       valid_lft forever preferred_lft forever
    inet6 fe80::f606:8dff:fecf:98eb/64 scope link.
       valid_lft forever preferred_lft forever
7: br-main_lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-main_lan
       valid_lft forever preferred_lft forever
    inet6 fd75:ee6d:dd8e:10::1/60 scope global.
       valid_lft forever preferred_lft forever
    inet6 fe80::f606:8dff:fecf:98ea/64 scope link.
       valid_lft forever preferred_lft forever
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-main_lan state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f606:8dff:fecf:98e9/64 scope link.
       valid_lft forever preferred_lft forever
9: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.11.120/24 brd 192.168.11.255 scope global wlan1
       valid_lft forever preferred_lft forever
    inet6 YYYY:e4:ef2d:100:f606:8dff:fecf:98e8/64 scope global dynamic.
       valid_lft 6223sec preferred_lft 823sec
    inet6 fe80::f606:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
10: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f6:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.179.108/24 brd 192.168.179.255 scope global wlan1-1
       valid_lft forever preferred_lft forever
    inet6 YYYY:e4:ef2d:101:f406:8dff:fecf:98e8/64 scope global dynamic.
       valid_lft 7123sec preferred_lft 1723sec
    inet6 fe80::f406:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
11: wlan1-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-main_lan state UP qlen 1000
    link/ether f2:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f006:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
12: wlan1-3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-guest_lan state UP qlen 1000
    link/ether fe:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc06:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
13: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-guest_lan state UP qlen 1000
    link/ether f6:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f406:8dff:fecf:98e9/64 scope link.
       valid_lft forever preferred_lft forever

ps

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:XX:XX:XX brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host.
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-main_lan state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel master br-guest_lan state DOWN qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
6: br-guest_lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-guest_lan
       valid_lft forever preferred_lft forever
    inet6 fd75:ee6d:dd8e::1/60 scope global.
       valid_lft forever preferred_lft forever
    inet6 fe80::f606:8dff:fecf:98eb/64 scope link.
       valid_lft forever preferred_lft forever
7: br-main_lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-main_lan
       valid_lft forever preferred_lft forever
    inet6 fd75:ee6d:dd8e:10::1/60 scope global.
       valid_lft forever preferred_lft forever
    inet6 fe80::f606:8dff:fecf:98ea/64 scope link.
       valid_lft forever preferred_lft forever
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-main_lan state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f606:8dff:fecf:98e9/64 scope link.
       valid_lft forever preferred_lft forever
9: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f4:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.11.120/24 brd 192.168.11.255 scope global wlan1
       valid_lft forever preferred_lft forever
    inet6 YYYY:e4:ef2d:100:f606:8dff:fecf:98e8/64 scope global dynamic.
       valid_lft 6223sec preferred_lft 823sec
    inet6 fe80::f606:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
10: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f6:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.179.108/24 brd 192.168.179.255 scope global wlan1-1
       valid_lft forever preferred_lft forever
    inet6 YYYY:e4:ef2d:101:f406:8dff:fecf:98e8/64 scope global dynamic.
       valid_lft 7123sec preferred_lft 1723sec
    inet6 fe80::f406:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
11: wlan1-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-main_lan state UP qlen 1000
    link/ether f2:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f006:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
12: wlan1-3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-guest_lan state UP qlen 1000
    link/ether fe:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc06:8dff:fecf:98e8/64 scope link.
       valid_lft forever preferred_lft forever
13: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-guest_lan state UP qlen 1000
    link/ether f6:06:8d:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f406:8dff:fecf:98e9/64 scope link.
       valid_lft forever preferred_lft forever

/var/etc/dnsmasq.conf.cfg01411c

# auto-generated config file from /etc/config/dhcp
conf-file=/etc/dnsmasq.conf
dhcp-authoritative
domain-needed
localise-queries
read-ethers
enable-ubus
expand-hosts
bind-dynamic
local-service
domain=lan
server=/lan/
dhcp-leasefile=/tmp/dhcp.leases
resolv-file=/tmp/resolv.conf.auto
stop-dns-rebind
rebind-localhost-ok
dhcp-broadcast=tag:needs-broadcast
addn-hosts=/tmp/hosts
conf-dir=/tmp/dnsmasq.d
user=dnsmasq
group=dnsmasq


dhcp-ignore-names=tag:dhcp_bogus_hostname
conf-file=/usr/share/dnsmasq/dhcpbogushostname.conf


bogus-priv
conf-file=/usr/share/dnsmasq/rfc6761.conf
no-dhcp-interface=br-guest_lan
no-dhcp-interface=br-main_lan

iptables

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Each radio can only be connected to an access point, you cannot have two STA on the same radio.

You could try to use one radio for each network. Or you can tunnel both networks inside one connection, for example using GRE.

Ok, I found out, that the dhcp section is indeed interpreted by odhcpd and if I remove it, there is also no ipv6 address assigned to the client,

@eduperez
Thank you very much! Disabling the guest wifi makes the main wifi work perfectly.
Using the other radio is a great idea, but sadly both networks are 2.4GHz only.
I did a quick search, if the main box (fritzbox 7430) supports GRE, but havent found anything usable.
Probably I try to use a VPN to connect to the main network from the guest.

I would have never thought that it is the problem to connect to two networks. The output of iwinfo seamed to be ok. Also I was able to use the guest2 and from the main network connect to the box with 192.168.11.120, but probably the box is just switching between both networks?

wlan1     ESSID: "main"
          Access Point: XX:XX:XX:XX:XX:XX
          Mode: Client  Channel: 11 (2.462 GHz)
          Tx-Power: 18 dBm  Link Quality: 41/70
          Signal: -69 dBm  Noise: -95 dBm 
          Bit Rate: 78.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

wlan1-1   ESSID: "guest"
          Access Point: XX:XX:XX:XX:XX:XX
          Mode: Client  Channel: 11 (2.462 GHz)
          Tx-Power: 18 dBm  Link Quality: 41/70
          Signal: -69 dBm  Noise: -95 dBm 
          Bit Rate: 43.3 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

Relayd is a kluge and it seems likely that running more than one instance would not work.

Unless you need the main router to track / account for guests, you could set up a local guest AP, locally route guests in your box and NAT to backhaul them through the main network. The firewall can be used to block guests from reaching any machines on the main network.