Bridge not working

I am trying to set up LinkSys EA6350 to bridge a VLan from another device. The EA6350 has two ethernet devices (eth1 connected to the "WLan" port, and eth0 connected to a switch to the four "Lan" ports).

I am trying to receive tagged vlan 2 traffic on port 1 of the LAN, and bridge it to eth1. This is the network configuration I'm using (generated using Luci):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd23:d828:979d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'
        option stp '1'

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr '60:38:e1:ac:b2:cc'

config device 'wan_eth1_dev'
        option name 'eth1'
        option macaddr '60:38:e1:ac:b2:cb'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 1t'

config interface 'External'
        option proto 'none'
        option ifname 'eth0.2 eth1'
        option type 'bridge'
        option stp '1'
        option force_link '1'
        option delegate '0'

If I'm trying to route Vlan 2 traffic to another port on the switch, everything works. Trying to route it to eth1, however, does not. The port does not seem to forward traffic.

I need help understanding what I'm doing wrong.

Thank you,

Tag switch port 0 in both VLANs. Then you have eth0.1 = lan (so you must change the physical setting in lan to be that not eth0) and eth0.2 = tagged packets from port 1. Also a good idea to take port 1 out of the LAN (VLAN 1).

Bottom line is though having tagged and untagged networks on the same port technically conform to standards, it rarely works on consumer grade hardware. Once you start tagging, tag everything.

1 Like

What version of Openwrt are you using?

Unless I'm mistaken, I didn't think vlans were proprerly supported (via LuCI) at this time for ipq40xx devices.

After some tweaking, here's what I found.

I can set any port except 0 to anything I want. There does not seem to be any problem with mixing tagged and untagged traffic, and everything works.

Port 0 (the "CPU", or eth0), however, I cannot set to tagged. It will not accept any tagged traffic.

My solution was to change my plans. Instead of giving vlan 2 as untagged on the "Internet" port (eth1), I'm giving it on port 4. I'm using eth1 for standard lan traffic. This way, only one vlan needs to be bridged across the CPU, and everything works.

Thank you for your help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.