Bridge LAN and WAN ethernet ports

I am currently using a Western Digital mynet750 router with OpenWRT as a switch. I have turned off the wifi radios. I am able to use the 4 LAN ethernet ports to split one incoming ethernet wire into 3 outgoing wires going to 3 downstream devices. I used the dumbap instructions, which says "there is no need to use the WAN port". Perhaps it means "please do not use the WAN port" because I don't see any instruction there to bridge the WAN interface with the LAN interface.
I now need to add a 4th downstream device. I want to be able to use the WAN ethernet port for the 4th downstream device. How do I configure openwrt to do that?

No problem, you should configure switch in /etc/config/network

See section Step 1: Modify the Network: https://openwrt.org/docs/guide-user/network/wifi/dumbap#step_1modify_the_network

3 Likes

Thanks. That worked. On my router, the settings were slightly different. Here are the changes I made:

@@ -18,18 +18,6 @@ config interface 'lan'
        option dns '192.168.1.1'
        option ifname 'eth0 eth0.1 eth0.2'
 
-config interface 'wan'
-       option ifname 'eth0.2'
-       option proto 'dhcp'
-
-config device 'wan_dev'
-       option name 'eth0.2'
-       option macaddr '00:90:a9:09:d3:3a'
-
-config interface 'wan6'
-       option ifname 'eth0.2'
-       option proto 'dhcpv6'
-
 config switch
        option name 'switch0'
        option reset '1'
@@ -38,10 +26,5 @@ config switch
 config switch_vlan
        option device 'switch0'
        option vlan '1'
-       option ports '1 2 3 4 0t'
-
-config switch_vlan
-       option device 'switch0'
-       option vlan '2'
-       option ports '5 0t'
+       option ports '1 2 3 4 5 0t'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.