Bridge a VLAN to a specific port solely for telephony via KPN provider

I've got FTTH installed today, I'd like to use my R7800 directly on the NTU. I've got a package deal with IPTV and telephony. So far I've got a working PPPoE tunnel which provides IPv4 and IPv6. Internet, WiFi, other networked devices via LAN work fine. IPTV is also working fine so far with an IGMP-proxy on the R7800.

There's one last thing I'd like to set up and that should be possible, but I'm kinda at a loss at the moment after reading a lot of information only to find out that this ISP has changed some settings the last few years so not every example is even accurate.

What I understand so far, is that I need to create a bridge between VLAN7 on the WAN side and VLAN7 on the LAN side. Only VLAN7 should end up tagged to one specific LAN port on the R7800 on which I connect the ISP's modem that does plain old VoIP-ata.

My eyes are spinning at the moment, does someone have a clue?

The easy solution to this would be adding VLAN7/ VID7, adding both WAN and your desired LAND port to it as tagged - and not even connecting the CPU port of your router to this VLAN.

1 Like

That sounds easy to do. I haven’t had the time to pick this up, last few days were packed with other amusement (amongst which Fathers Day).

I’ll post my config since I think I’ve got that setup already for 95% without actually understanding the details.
--EDIT--
Here's my current config:

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd74:6331:6d2b::/48'
	option packet_steering '1'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '9.9.9.9'
	list dns '149.112.112.112'
	list dns '2620:fe::fe'
	option force_link '0'
	option device 'br-lan'

config interface 'wan'
	option device 'eth0.6'
	option proto 'pppoe'
	option username 'REDACTED'
	option password 'REDACTED'
	option ipv6 'auto'
	option peerdns '0'
	list dns '9.9.9.9'
	list dns '149.112.112.112'
	list dns '2620:fe::fe'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'eth0.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 4 3 2 1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 5t'
	option vid '4'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '6'
	option ports '0t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '7'
	option ports '0t 1t 5t'

config interface 'IPTV_WAN'
	option proto 'dhcp'
	option device 'eth0.4'
	option peerdns '0'
	option delegate '0'
	option defaultroute '0'
	option vendorid 'IPTV_RG'

config route
	option interface 'IPTV_WAN'
	option target '213.75.112.0/21'
	option gateway '10.138.64.1'

And here's LuCI shows that:


From the looks of it, I'd say it's already configured like I thought it should be. The modem from the ISP should pick that up and act as a VoIP ATA, but it doesn't. It's likely I made an error in my OpenWRT config, it's also likely I need to do something on the ISP's modem too :grin: