Bridge 2 different ip-ranges

Firstly I'd like to say that I'm not great at networking, and hopefully I ask the right questions.

My current setup is a fibre router, and I have a dlink router (dir-882 a1) connected to it running openwrt (v23.05.0). Everything (wired and wireless) is connected to the dlink. I recently changed ISP and only then started to have trouble with my port forwarding that I have in openwrt.
Openwrt is running 192.168.1, 255.255.255.0 but the fibre router is running 100.71.64.1, 255.255.192.0. I dont know much about IP adresses and subnet masks, but I feel like these two cannot communicate if they're so different.

When I connect my computer to the dlink router, I can see my server (at 192.168.146), but I cannot see it when I connect to the fibre router.

I have a feeling that my port forwarding issues stem from the fact that the 2 routers are running on different ip ranges, maybe?

I would rather not change the ipaddress range on the dlink (if required), but I have no access to the settings in the fibre router.

Any help is greatly appreciated!


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd64:dfa5:808c::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '100.71.64.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

This IP indicates your ISP uses CGNAT. That is probably what has caused your issues.

1 Like

Your Port Forwarding is probably caused by CGNAT , your ISP provider does not give you a publicly available IPv4 address so you cannot port forward.

Ask with your ISP provider if this is the case and if they can provide you with a public IPv4 address.

Alternatively you maybe have an IPv6 address you can use

1 Like

Okay. I spoke with them yesterday and today, and they said I needed a public ip, which they have assigned me. But apparently today they tell me that the public ip hasn't taken affect yet, and I will need to disconnect my router for several hours so that it picks up the new address when it reconnects.

It sounds like from you and @krazeh, the main problem is a public IPv4 address. I hope that this 6 hour disconnection will help with that, and therefore fix my issues.

I'll let you know!

2 Likes