Bricked Xiaomi R4A gigabit edition 1200AC router

Hi everyone

First of all thanks to these awesome developers for creating and maintaining openwrt..

I have been using Openwrt on my Xiaomi router since the last 6 months everything was going good..

Recently ( because of my stupidness ) I wanted to clean up unused packages on my openwrt firmware so I ran the command "opkg remove --autoremove '*'"

Which mostly crashed my router and deleted important router packages such as luci app kmod for mt76x2 etc etc

Now the router was still on for few hours It was night so I thought I would fix it back to normal tomorrow router had 2 leds of which both of them was solid blue at that time ( means router was working as expected)

But the next day I woke and saw all of my connected devices from the router was disconnected and even Ethernet connect wasn't working at all and the router's LEDs were blinking yellow.

I am attaching the current situation of my router

Please help me restore the router back to working state

Thank you

If you problems playing the video then you can try downloading the video

For R4A, please open the plastic back cover, check the flash IC p/n.

Better you connect the Uart to a UART-USB adaptor to check the log data.

What is factory fw version no? When did you buy this R4A?

Did you try a "factory RESET" for the openwrt? e.g. After power-on, then press and hold the Reset Button for ~10s.

I am no serial programmer can use Ethernet cable with pc eg tftp etc

And yeah router was brought around 10th of December 2020

It's an old production set, no problem you use TFTP to debrick it.

Press and hold the Reset Button, then power-on, until the LED flash fast, then open the TinyPXE tftp server, you know it.

1 Like

You mean it will blink a lot faster than the given video above ?

almost same frequency, but non-stop.

1 Like

But what shall be the configurations of the

Ip, gateway, and subnet

And I think I will have to flash Xiaomi's original firmware and I can't flash openwrt firmware directly via this tftp method right ?

Yes I think I saw it once but ignored

Can not recover to openwrt! You have to go back factory first.

PC static IP:, and turn OFF the firewall.

TinyPXE, defaults.

1 Like

Is this working?

Routers system led is Blinking and blue colour

Also this is my Pxe config

Router has been blinking
Like this for about 35 minutes

You should back to factory fw already. Change the PC IP back to DHCP. Then Xiaomi router initial page will be on

But why system led is still blinking

try to reboot and access, maybe auto-open.

I noticed you used factory fw 3.0.24, if this not work, please try 2.28.xx again.

Can you send Xiaomi 2.28xxx international bin file for R4A gigabit?

I donot have 2.28.xx international version. Only Chinese version:

Should recover the situation.

Thanks anyway router worked as you said to power off and on again

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.