Bricked? WRT32X

I was trying to switch from DD-WRT to OpenWRT, and rushed in a bit (which isn't like me, at all, go figure) and I basically gave my router a lobotomy, and it sits brain dead. I purchased an Adafruit serial to TTL cable, and connected it like everyone says, and followed the instructions for stopping the boot sequence and issuing environment changes, but all I get from Puttyt is a black screen, and the LAN light shows data traffic. No power light.
I discovered quite by accident, that if I removed the black, ground wire, and left the TX and RX attached, and powered up the router, I got a screen full of data, showing the boot sequence I presume, and it gets to a certain spot and just stops...I've mashed every manner of key trying to stop it, break it or otherwise interrupt the boot, to no avail. I am left with the blue LAN light, flashing, showing data traffic I assume, and the power light blinking slowly, steadily...and nothing more...
I've tried it on my windows PC, I've tried it on my MAC, I've even tried it on my PC in a Debian VMware environment, and using KWBOOT, and KWBOOT-PATCHED, trying to restore a working uboot..with no success.
If anyone can shed any light, or insight, I would be so very appreciative...Thanks in advance..

Keep GND connected and disconnect the USB2serial adapter's TX line until just a fraction of a second after providing power to the router. With GND and TX of the USB2serial adapter you do leak current into the router SOC, which might be enough to put it into a weird state it can't boot from.

1 Like

Agreed with above.
When I was connecting serial to this device (with the adafruit adapter) I couldn’t get it to boot without wiggling the connectors. I don’t think they’re quite the right size.

Once it starts booting just keep pressing enter to interrupt the boot. If it progresses too far you won’t see any output as the console is silent=1 from factory.

... and are you sure there is not still a viable image extant on the other partition available by way of using the power switch.

Yes, I agree the connectors are POS..crap..junk. but anyway. I tried to remove the TX like was suggested, didnt work..BUT.. that made me think to try again, what I had tried before, but this time with a bit more interest in timing..I did the same with the black ground and on one of my attempts I got a prompt. I've been fiddling with that ever since..trying various commands and methods I've found..not all directed at the WRT32X..some of the env variables I tinkered with, and / or..the updates I tried, made a difference..I now have a "hit any key to stop autoboot"
And I'm back at a prompt.

I dont think the image I have is formatted for serial update, and I have not succeeded in finding online a copy of the flat-formatted serial version of the stock firmware..

I'm stuck..

I tried to upload the boot file..something didn't work..tried uploading the venom.img which didnt work..think that's the improperly formatted stock firmware..

Last message in boot output looks like it tried to load from one of the partitions.

"Bad Linux ARM image magic!"

There’s a correctly formatted stock image on the DDWRT forum somewhere. It was posted by “spuriousoffspring” and I used it to recover my device in the past.
You can’t see attachments on that forum unless you sign up.


the 'silent=1' defaualt is problematic for debugging.
what I had to do once or twice:

from serial console, hit ^c to interrupt boot. it may or may not work.
when all the activity has stopped, type these lines; they may not be echoed:
setenv silent

see these posts:

That’s not entirely necessary.
If you halt the boot, and then either “run nandboot” or “run altnandboot” the silent flag isn’t passed in so you can debug it fine without touching the default environment.

@lantis - great to know. thank you for your knowledge!
is the default silent=1 necessary for anything? would it be possible to binary modify the uboot with default silent=0 or nothing?

Not that i know of, but i like to leave well enough alone in case :wink:
I'm sure you could, although an easier option (and one i thought of doing when i added in support for the device) was setting that value to 0 on first flash (or every flash).

I've seen that post and couldn't figure out where the attachment was. How do I know what "stage" I'm at right now? Is my uboot ok? Will the correctly formatted image take care of everything else?

I tried several images last night, without success. Wasted a lot of hours fighting this thing..hopefully, today, after breakfast..I'll make some progress.. thanks for all the input, gang!!


Is it not possible to tftp an image(OEM | owrt) over a dd-wrt image.

That firmware did the trick. Its booted up, waiting for to see if I can get openWRT installed. Does it still have issues with 5G?
I was switching from DD-WRT because my golf clash was losing connection, not the wifi connection, just the game talking to the servers.

The apple airport that has been standing in for the linksys hasnt caused a bit of trouble with the game connection. So, I know it was something in the prior setup. That's not the only issue, but it was a big one for me..I'm a golf clash addict..I admit

Any pitfalls I should be aware of before I begin this endeavour with oprnWRT?

Thanks everyone!!


If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

For any other questions regarding installation / configuration of OpenWrt, please open a new topic in the appropriate subforum.

The solution was actually a combination of things. The first being the cheap, loose connectors on the adafruit cable not making appropriate contact, and having to be "jiggled" to work..The second being the correctly formatted firmware image, which I downloaded from from the DD-WRT forum. I was very disappointed that the file was so difficult to find online. So, that solves that problem, now I have to go start another topic to get some help with some issues I've encountered with Open WRT so far.. :slight_smile:
Thanks to everyone, for the much needed help.



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.