Bricked wdr4900 - Unbricked


I stupidly installed a v2 firmware on a wdr4900 v1.3 :confounded:

Now when I try to start it for TFTP flashing only the power light comes on. If I plug in the lan cable and connect it to my macbook pro (with IP that light comes on as well, but I cant see anything in the logs for Tftp server.

I've tried starting the router with the WPS button pressed but with the same result.

I also tried to connect a serial console but I'm getting nothing. The serial console cable is a Chinese version of the DKU-5 (I have had success in the past). The cables are green,white and blue and I'm not really sure which is which, so have tried a few different configurations.

Is the route fried beyond repair? Any idea on the cable?

Thankful for any advice!

I would at least measure GND to sort this variable out. Perhaps also check this thread

I decided to get a new usb/serial dongle with clearly marked pins.

Wow it worked.
I managed to get an old serial dongle to work.

Once connected through minicom I could see the boot up log.

U-Boot 2010.12-svn15934 (Dec 11 2012 - 16:23:49)

CPU: P1014, Version: 1.0, (0x80f10110)
Core: E500, Version: 5.1, (0x80212151)
Clock Configuration:
CPU0:800 MHz,
CCB:400 MHz,
DDR:333.333 MHz (666.667 MT/s data rate) (Asynchronous), IFC:100 MHz
L1: D-cache 32 kB enabled
I-cache 32 kB enabled
Board: P1014Autobooting in 1 seconds
SF: Detected S25FL128S_64K with page size 256, total 16 MiB
16384 KiB S25FL128S_64K at 0:0 is now current device
SPI flash read successful
SPI flash read successful
Wrong Image Format for bootm command
ERROR: can't get kernel image!

I then issued the tftpboot command to get the file.
I had to rename the file uImage or it wouldnt work.

Once the file was downloaded I erased the flash

=> sf erase 0x60000 0xf80000

and then write the new flash

=> sf write 0x1000000 0x60000 0xf80000

and then reset to restart it and the router came back to life!!

I followed your link and also this

Thank you so much for your help!

Thanks, nice to hear but you did all the work didn't gave up :- )

One thing about the cable thingy: iirc I used a serial/serial including level conversion and had to connect Vcc

:slight_smile:yes it was close though but then I remembered (after ordering a new one) a which had clearly marked RX/TX/GND.

And once I got the boot up it was quite easy to follow the instructions. Now considering leaving the cables soldered in place, just in case.