Bricked TP-Link TL-WPA8631P v3

So that means I could install the master right?

No, XM25QH64A means you can safely sysupgrade the existing official 22.03.3 release. Copy the file to your device somehow, then just do:

sysupgrade openwrt-22.03.3-ramips-mt7621-tplink_tl-wpa8631p-v3-squashfs-sysupgrade.bin

See the generic sysupgrade instructions for more information.
Do not use the -F force option, there is no need with OpenWrt sysupgrade files, and not using -F helps prevent accidentally flashing the wrong file which can brick this.

You are brilliant! Thank you so much!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

That was for a side issue, the original thread issue of specific flash chip support is still open, pending PR merge and follow up testing, so we should keep the thread open until then.

Thanks for getting old threads closed though :slight_smile:

1 Like

I couldn't follow the steps outlined in your reference. There was no pencil and when I klicked on the three dots there was no solution button. Sorry.

Hi @OpenK, you can disregard that message, see my previous reply. Also AFAIK only the original poster @raphidae can mark threads as resolved, and that should be done after this PR is merged and released to 22.03.4, which according to the mailing list will happen soon.

Fix merged into /openwrt-22.03, so this will make it into 22.03.4, due out in the next week or so.

In the meantime, waiting for the 22.03-SNAPSHOT build containing this commit to finish. Once that's built, we can give it one more test (e.g. @g0-07?) to confirm it will work for 22.03.4, and that no further changes to /openwrt-22.03 are needed before its released. Just sysupgrading to that new build and verifying the right flash chip shows up in the dmesg logs should be enough.


If anyone's WPA8631 device is still bricked due to this issue, you should post again in the thread and we can try give some more suggestions on how to recover.


Update: The SNAPSHOT-22.03 build containing this is ready for testing here

Hi! Eagerly waiting for 22.03.4 as I intended to buy this powerlink adapter. Just for curiosity: did you pair two TL-WPA8631P or did you go with the TL-PA8010P/TL-WPA8631P combo? I think the TL-PA8010P is not capable of running OpenWrt, so I was just wondering whether a "mixed setup" (TL-PA8010P/TL-WPA8631P) would work or you needed two TL-WPA8631P.
Thanks!

The TL-WPA8631P running OpenWrt can work OK with the TL-PA8010P running its stock firmware.

The TL-PA8010P is a simple Layer 2 Ethernet-to-PLC bridge, it doesn't do any routing or packet processing, it just connects the ethernet port directly to the QCA7550 PLC modem. So you wouldn't really want or need custom firmware on it anyway.

The TL-WPA8631P is basically a standard WiFi/Ethernet router with an independent QCA7550 PLC modem connected internally to one of the switch ports. It would be similar-ish to a regular router having a PA8010P plugged into one of its Ethernet ports, in one convenient package.

From OpenWrt running on the WPA8631, you can send commands to the internal QCA7550 to pair with other HomePlug AV2 devices, change the password etc. OpenWrt doesn't otherwise affect the QCA7550 firmware.

1 Like

Thanks a lot. so buying a kit with TL-PA8010P/TL-WPA8631P combo it is. After the new OpenWrt version is released :-).

kr

Finally 22.03.4 is out. According to the change log XM25QH64C is supported now. Can anybody confirm whether flashing 22.03.4 to WPA8631 is working?
Thanks upfront!
KR

I finally managed to unbrick my device. I've tried 22.03.4 and I can confirm it works with the XM25QH64C found on my device. Thanks a lot @jwmullally !

1 Like

Thanks @samkay, looks like this issue is all fixed then. I've updated the warning message on the wiki to just say:

Unless you really know what flash chip you have, you should install 22.03.4 and later.

@raphidae you can mark this thread as resolved when you are ready.

Thanks also from my side! Ordered a TL-WPA8631P v3 kit and flashed OpenWrt 22.03.4 flawlessly. However, unfortunately I have the XM25QH64A chip :frowning: (figured it out after flashing). But it works. Now it's up to check whether VLANs would work :-)!

Really a lot of thanks to everyone!
KR

No problem with the previous chip aside from the unnecessary wait, should work just the same.

Something I forgot to check was whether the current spi-max-frequency in the dts is low enough for all expected chips, but from a quick skim of the data sheets it looks like things should be Ok as-is.

If multiple people with XM25QH64C notices any regular flash related corruption, we'll have to try lowering that speed.

Hi again! I ordered anotherTL-WPA8631P3 - unfortunately this is v4 and trying to flash OpenWrt via the web interface fails with a "wrong image" message. Anyone any experience with v4?

Thanks in advance!
KR

I don't think v4 is supported. Onlt the v3 appears to exist in the table of hardware and also the available firmware images for download.

For WPA8631P v4, I opened a new thread here

As mentioned above here, this thread can be marked as resolved as the original issue is fixed.