Bricked TP Link Archer C50 v4

Hello Community,

I would to use OpenWRT but i maked a silly thing, I've install OpenWRT like it explained in the wiki under the section "Archer C50 v4 installation instructions" i decided to flash the pre compiled boot.bin from the dropbox .zip that worked well, but then i done the next step "Download tplink_C50-v4-squashfs-sysupgrade.bin for OpenWrt 19.07.x stable. You can use LuCI to install the sysupgrade.bin file." after this i didn't have anymore LuCI, then i connected me with ssh to my router and tried to install LuCI but the package wasn't found even after opkg update, then I decided to "rollback" to my first installation with the boot.img(because the most things worked there), so i pushed the boot.bin to my router over scp and made sysupgrade --force boot.bin (Now I know it was silly) and now my router goes on but after 2-3 sec it goes off and turn on again(endless).

Please Help Me.

Thanks in advantage for any help.

From the OpenWRTforArcherC50v4(EU).zip file, try reinstalling openwrt using TFTP method using the custom tp_recovery.bin file

Installing via TFTP
File required:  tp_recovery.bin

Place tp_recovery.bin in root directory of TFTP server and listen on

Connect router LAN ports with your computer and power up the router
while pressing the reset button. The router will download the image via
tftp and after ~1 Minute reboot into OpenWRT.

Here is one randomly googled video. Uses TFTPD32/64 for Windows.

(boot.bin is only for flashing from TPlink GUI)

May be when you install 19.07.0 stable via Luci, do Not 'Keep Settings' ?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.