Bricked TP-Link Archer A6/C6 v2 (US), TFTP is erratic

Important posts here Follow on conversation for TP-Link Archer A6 v2 5GHz improvements, including user support where I began flashing stuff.

I was unsatisfied with my Archer C6's behavior on Stock Firmware. Absurdly low speeds on 2.4Ghz and issues that persisted within reboots. Thought of giving OpenWRT a shot, unfortunately, there's only snapshots builds. I thought it wouldn't be much of an issue... Well, until I flashed it and hell began.

The two builds I tried didn't give me an impression that OpenWRT was as stable or solid on that device yet. I then decided to attempt to revert the firmware to Stock...

Usual TFTP methods, 192.168.0.66, hold Reset until WPS Led comes on.
No matter how many times I tried, oldest firmware from TP-Link's website, newest firmware.
The file would get sent but the router would reboot to OpenWRT as if nothing had been flashed. It seemed like it was rejecting the firmware images it was receiving.

Looks fine on TFTPD, but then... Nothing.

image

I googled a bit and it looked like the only solution was to webflash from OWRT a stripped stock firmware image. I used dd to strip it, force flashed it through webflash. Soft-Bricked, nothing boots now.

I still get TFTP/Recovery Mode to send files to the router. It is not a hard brick. However, like before, the router seems to reject every single firmware I send to it. No matter what I try. Stripped stock, stock not stripped. Factory OWRT, Sysupgrade OWRT. I turn it on Recovery Mode, tftpd64 sends the file successfully, the WPS LED eventually turns off after the flash and for a good while nothing happens. No reboots, no firmware gets flashed and even if I manually reboot I'll be stuck on a dead soft bricked firmware state.

More information about my issues can be found at:

At this point I have a paperweight on my desk and I'm willing to try whatever's possible to fix it.

I have extra, new in box, hardware to test with - if it helps anyone on this thread.

1 Like

Hm, if I were to request anything is to verify if you can flash OpenWRT and revert the firmware using TFTP. To be fair my brick is just still a thing because TFTP despite sending the file correctly something in between happens and my router denies the update?

check my comments over here Follow on conversation for TP-Link Archer A6 v2 5GHz improvements, including user support

1 Like