Bricked router

So my internet went down on ISP part and i went under the desk to check what is wrong, unplugged lan wan plugged them back more than once and bang!! router went in brick mode. This is really beyond my understanding why, but it happened. I purchased USB-UART and Console cables hanged them to minicom but none give any output, tested minicom with spare old router and it printed boot log perfectly so it works, hanged to bricked router prints nothing but some unreadable symbol from time to time at switching device on, nothing else. Router is comfast ac101, all i get is power on light and one light on lan port, system light is off, no network connection to the router, wireshark shows no pockets are transmitted
My question is, is it totally bricked junk or i'm missing something, any idea as to how to proceed? are the typical unbrick minicom settings wrong for this router?
I know it is not really openwrt router but i believe you guys have the best know how
Thanks in advance

It's dead Jim.

Could it be possible that this was caused by wrong settings? E.g. baudrate, parity bit etc.

he (router) has to be really unhappy with his life to leave me suddenly and without the adequate reason, unless ISP sends 400v over the WAN with the idea of destroying customer appliances i find it hard to believe it is just gone. I gonna test all the other baudrates bits and such, hope there is some chance left

Yep, seems weird. Nevertheless the fact is that

I assume you've tried doing fail-safe mode, by pressing some button during the initial bootup phase right? If you don't see any packets on wireshark while doing this fail-safe boot it's a pretty safe bet it's dead.

Yep, i went through all ports again with and without reset pressed wireshark reported nothing,
Will resetting flash chip have any effect in this case or it is reserved to "less" bricked devices that report stuff on lan or tty interface? Anything else i can try before writing obituary on this thing?

It's dead Jim.

About the only chance you'd have is to write the flash bit-by-bit using a JTAG interface if it even has one (assuming there isn't any actual hardware failure, which seems unlikely). I can't imagine doing that is worth your time and effort and the cost of buying equipment to make it happen (and lots of devices don't have a JTAG).

I'm guessing that maybe a static discharge or power surge or capacitor failure or something happened and fried an important component.

1 Like

if that one has 16mb flash get a ch341a and dump its content. if you messed bootloader only you can still save wifi calibration and board specific data, then look how to restore it working state...

The whole situation is so weird ,I mean how can it just die when all u did was replug lan and wan.. it doesn't make sense. U mentioned "unreadable symbol " in console when connected via serial. It could be due to mismatch of settings or no bootloader all.

Sometimes for serial to work correctly a 1k ohm resistor is necessary between tx and gnd. Otherwise last resort is like others mentioned is to reprogram the flash ic using programmer. U can buy one of those ic clips, with it u can flash without desoldering the chip.

Is there a factory reset button/pin hole?

I'm still suspecting somehow minicom is not properly set for the job but i have tried nearly all settings by now so maybe it is that 1k resistor that is missing.
Yes there is JTAG nicely defined on pcb (no socket) but going that way is beyond my will to have it fixed
Yes there is reset button, i have tried to boot with the reset pressed, the only thing i didn't is an hammer.
The curious thing about it, is that i have few wall AP by comfast, one of them bricked while flashing openwrt, what happens is that AP boots and i see the net traffic on wireshark but minicom shows only "?" symbol, so it may be missing resistor after all, i will dive into that in free time and try to build custom openwrt image
Let's see the resistor effect on tty but i already see the gateway going in dumpster direction and me asking you for guidance on building custom openwrt images