Bricked R7800 NO ethernet LEDS

Im crying here any help greatly appreciated.
I have been running Kongs October build on my R7800. Decided this morning to hold reset button in with intentions of doing a fresh install. For some reason it appeared to get stuck on a flashing orange power LED so I thought I had no option but turn off and back on. NOW when holding reset and powering on I get to the flashing white power but no ethernet leds light up and even laptop says no cable connected. Tried another cable no joy. If I run a cable from my other router and power on, both WAN and power are solid white. Is this now only fit for bin considering I cant get a tftp connection now :frowning:

Afaik OpenWRT uses u-boot to do the tftp recovery, but it should always work unless OpenWRT busted the recovery somehow.
@KONG Any ideas since it's your build?

Thanks for the reply this one is wierd. I just tried again and although recovery/tftp mode said the status was connected trying to tftp the squashfs.bin file just returns a timed out message. I have just tried to enter the recovery mode again and after releasing the reset button once the power was flashing steady white the unit rebooted itself about 20 seconds later. Exact order was:
powered off
start recovery
reset held down
powered on
steady orange
flash orange
steady white
flash white
release reset
unit reboots but still no ethernet port LEDS when cables are connected

Impossible to know what's going on without serial console. But it feels like it doesn't load the ethernet drivers for some reason. Have you tried putting a switch between the router and the laptop? That way you will see if the ports lights up on the switch. Try all ports on the router just to be sure.

1 Like

Thank you. This really is bizarre. I took your advice and connected Lan port to switch and PC to switch. Straight away I noticed the switch lights working and I managed to successfully tftp Netgear stock image to router. Router rebooted fine, I set admin password using stock UI once all that was completed I flashed Kongs latest factory.img all seemed good and router rebooted and here I am again no LAN lights when connected directly from PC to router Lan port. Put the switch back in the middle and it seems like I see a solid connection from router lan port to switch but intermittent between laptop and switch.

UPDATE. Tftp back to stock again for testing purposes. if I connect switch to any Ethernet port on router the LEDs and that particular port on router work fine. Connect the pc and port does not light up or work. WiFi works fine too

Did you try new cable and different pc? It is very unlikely, that it has to do with the firmware. No changes in the BSP code for a while, and if a switch works, it is also not possible, that the bootloader parts are broken.


Indeed, this seems like a PC or cable issue.

The problem you have with the router not booting after a reboot, I've had similar issues. Just try another build and see if it helps. Like the build from hnyman.

1 Like

Yes tried a few cables but with the laptop costing so much and only being about 5 months old I didn't think for one minute it could be to blame.
I have just pulled an old Samsung out and the switched it on and the port fired right up so yes guys it appears to be my hardware.
Thank you @shelterx and thank you @KONG the confirmation that no code changes could have been a factor were really helpful. REALLY REALLY APPRECIATE THE HELP

Did you check the laptops ethernet driver settings, maybe different settings like auto speed configuration or power management settings make a difference.

No I didn't. Very good point, I shall try to pin down a little better today thank you

@Chief not to blame mate. The laptops config has not altered at all so no need to look at bios settings that combined with the fact we are not even getting to the os loading stage rules out this being a software problem

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.