Bricked my EdgeRouter X upgrading to 19.07, help needed

I tried to upgrade my EdgeRouter X from 18.06 to 19.07 using the following steps:

  1. Downloaded openwrt-19.07.0-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin from the official site
  2. Checked the hash was correct
  3. Upgraded using LuCI
  4. EdgeRouter X never came back from life.

At step 4, the file hash reported by LuCI was different from that reported by my checksum command, and I'm pretty sure I didn't pick the wrong file, because I had only one bin file in my folder.

Since I had manually checked the hash, I went ahead and let it upgrade.

Now when I power the device on, only the power LED is lit, not flashing, and intermittently, all LEDs light very briefly and dimly. I can't get into failsafe mode following the steps in the doc, and there is no UDP packet with port 4919 captured on my computer (manually set IP to, and gateway to Long-pressing the reset also doesn't help.

Is it possible to debrick? Is the series console my only hope now?

Looks like it.

I don't understand why you noticed the checksum mismatch and chose to ignore it? Just because the file is OK on your computer doesn't mean it transferred correctly through your browser to the router.


Please check if this helps: Edgerouter X wiki points to not working .BIN and other thingies

Truth to be told, I tried twice. The first time LuCI reported mismatch I didn't upgrade, went back browser history and refreshed; The second time it still reported mismatch, at that point I just assumed LuCI didn't calculate right.

Thanks, I also found that post.

But after pressing the reset button for a long time, after all LEDs lit up and then turned off (on and off twice), they never came back on, not like what the ubnt doc has mentioned: "the port LEDs will continuously turn on and off while the TFTP recovery mode is active."

And manually setting my IP and gateway didn't work either. tftp complained "tftp: sendto: Network is unreachable", when I tried to put to