Bricked MR3040 v2 [solved]


I don't know where else to ask this. I will come to the point, I need full flash dump of this router to reprogram flash IC since I believe the current one is damaged somehow.

Currently it has Spansion FL032PIF. So I will try to replace it with Winbond 25Q32 or similar, just need the flash dump. If anyone could help, I would really appreciate it.

I don't know what happened to it, the router was being used as print server and it worked great for months, and one morning I made quick print job and turned it off, an hour later when I tried to start it again only the power led glows and that's it.
No, tftp, no serial, nothing. just a paperweight now. So I think the flash IC might be done for.



So I actually thought the EEPROM was somehow bad or the data in it was incorrect. I de-soldered the chip and it's being read, write and verify just fine. How do I confirm that chip is OK?

Problem appears to be something else entirely. Perhaps some other component has failed. I figured half of the board is not being powered at all. Going any further is beyond the scope of my expertise. So I'm giving up. This was a wonderful router. Will always be remembered.