Bricked Linksys e8450 w/ UBI bootloader from dangowrt

new brick here-
i had the ubi loader from dangowrt - https://github.ink/dangowrt/owrt-ubi-installer/releases
running version 1.0.0 with openwrt 22.03 as in this page
https://github.ink/dangowrt/owrt-ubi-installer/releases/tag/v1.0.0 for more than a year.
i needed to upgrade the ubi loader to get on newer kernels so went ahead to flash the new ubi conveter https://github.ink/dangowrt/owrt-ubi-installer/releases/tag/v1.1.1

my e8450 is now bricked at the early BL stage.
here is the serial output; if i press nothing it hangs;

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 01B4 [000F]
Jump to BL

NOTICE:  BL2: v2.4(release):OpenWrt v2021-05-08-d2c75b21-1 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 12:38:48, Jan 27 2022
NOTICE:  SPI-NAND: FM35Q1GA (128MB)
ERROR:   BL2: Failed to load image id 3 (-2)
3333
F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 01B4 [000F]
Jump to BL

NOTICE:  BL2: v2.4(release):OpenWrt v2021-05-08-d2c75b21-1 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 12:38:48, Jan 27 2022
NOTICE:  SPI-NAND: FM35Q1GA (128MB)
ERROR:   BL2: Failed to load image id 3 (-2)
44444
F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 01C9 [000F]

i tried a bunch of keypresses; the only thing that got anywhere was the 'c' key.
if ihold the 'c' key, i get a [B} prompt but don't know the next steps and the bootloader times out after about 30 sec:

F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 02AE [000F]
Jump to BL

NOTICE:  BL2: v2.4(release):OpenWrt v2021-05-08-d2c75b21-1 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 12:38:48, Jan 27 2022
NOTICE:  SPI-NAND: FM35Q1GA (128MB)
ERROR:   BL2: Failed to load image id 3 (-2)
ddddd
F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
[B]cccccccccccccccccccccccccc
[B]
F0: 102B 0000
F6: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 0400 0041 [0000]
G0: 1190 0000
T0: 0000 02AE [000F]
Jump to BL

NOTICE:  BL2: v2.4(release):OpenWrt v2021-05-08-d2c75b21-1 (mt7622-snand-1ddr)
NOTICE:  BL2: Built : 12:38:48, Jan 27 2022
NOTICE:  SPI-NAND: FM35Q1GA (128MB)
ERROR:   BL2: Failed to load image id 3 (-2)


any help for this level of brokenness?

You can use mtk_uartboot to recover. Search for that here in the forum, you will find detailed instructions.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.