Bricked Linksys e4200 v1

I'm trying to install openWrt on my e4200 v1

I did that through the web gui, but the router didn't assign an IP after reboot.

Some googling led me to the TFTP method to revive the router and flash back the original fw, but nothing is working

TFTP gets stuck at around 70% (see screenshot)
I tried cmd TFTP too... tftp -i router PUT linksys.bin

I can however flash smaller .bin files, could it be that openWrt ruined the partition on the router and now it can only handle <8mb fw files?

I tried reset 1mnt, in order to erase everything but won't work either.

DHCP is not working except for when I go into TFTP mode.

what are my options?

Screenshot 2021-01-27 180340

I've got a similar problem, I guess - a bricked E4200 v1.
Upon plugging the power, it starts blinking, but nothing further.
After connecting to a computer, an IP address is given from a DHCP (router is at
When I try loading the router in the browser - does not work; ssh to it does not work.
TFTP does not work (probably as I don't know how to TFTP it, but I did give it a try with default values).
When I try pinging the router, it is reachable with TTL=100 all of the time.
Any suggestions?

P.S. I am unsure what was the distribution on it beforehand, it was gifted to me some time ago, but I do not have an idea of the distribution of it.

fwiw, from experience of bricking other Broadcom based routers of that era when testing other firmwares (Tomato, ddwrt etc), you may have to use a serial connection to erase the NVRAM.

OpenWrt support for Broadcom devices is poor. I suggest looking at better alternatives such as FreshTomato.

.. And could at least one person explain in very details the TFTP process?

I seem not to be able to find it anywhere, but in the given JTAG thread, it forwards to Serial Connection thread where upon the progress they mention that they upload the firmware (the .bin file) with TFTP.

But from my experience, I haven't been able to make TFTP work with my working Linksys routers..

Thank you in advance!

I'm afraid there may be very little expertise on this forum, for such a 11 year old Broadcom router. OpenWrt support for Broadcom devices is poor. OpenWrt favour Qualcomm based devices imho. There is no dedicated openwrt device page for the E4200 v1.

I suggest you ask the ddwrt forum for specific advice how to unbrick e4200 v1 and restore Linksys firmware, as they have far more Broadcom device expertise.

fwiw, I think you need a serial-TTL connection (not JTAG) in first instance, to access the router. Erasing the corrupted NVRAM may (or may not) help solve some problems. It has worked for me for Belkin and Linksys Broadcom routers from around 2010.

I recall Linksys made their own windows tftp utility to recover their own routers, but in my own limited experience, I never got it to work to unbrick a linksys (E3200?) router from 2010, if the router had been previously flashed/bricked with non-linksys firmwares and the NVRAM was corrupt.

Thank you! And about the process with the serial connection, I somewhere found 3-4 commands - one was for erasing the NVRAM.
What I recall the process was something like:

  1. Keep hitting CTRL + C (but I don't know what software to)
  1. Once there, flush the NVRAM
  2. Restart the router
  3. Upload the Linksys firmware using TFTP
  4. The router will process it itself (no need of manual jobs)

Would you share me the step-by-step guide (including commands, please) of your process for restoring using serial connection method?

Sorry, I never had to restore stock firmware as far as I recall. The E3200 I once had was over 5 years ago. Erasing NVRAM always solved the problem for me (most recent was fixing a belkin f7d4302 before xmas), causing newly installed 3rd party firmware to boot after clearing corrupted NVRAM. You will have to ask on ddwrt forum if you wish to restore stock firmware.

I use PuTTY for windows with a serial-TTL usb adapter (PL2303TA is windows 10 compatible.)

This may help, for E900

Many Broadcom bootloaders have web recovery.

Hold down the reset button while turning the power on. Keep holding until after the LEDs blink an unusual way then let go of the button.

Connect PC by Ethernet (usually to a LAN port, but if that doesn't work try WAN). Static IP PC to Browse to router at You should see a single page with options to flash firmware (which works best with stock firmware) and maybe to erase the NVRAM.

Offtopic, but allow me to put this into context.What you are seeing is the result of deliberate corporate policies. For me, personally, Qualcomm is in the doghouse for their shenanigans with ath10k.

Broadcom doesn't care about FOSS. Qualcomm pretends to. The ath9k driver (which they did not write themselves, mind you) didn't need blobs and was stable which made the hardware wildly popular - it was long the only hardware that was decently supported (!). QCA wanted to capitalise on that with ath10k and up but they closed up all the good stuff.

I understand what you were trying to convey, but please realise your choice of words makes for a misleading statement. Fanboys apart, the community will recommend what's best supported. OpenWrt does not favour anything. Developers port hardware that stands a chance of being supported - and usable.

To put your statement into context: my backbone is comprised of Realtek based switches. MediaTek edge router and access points. A Marvell based edge router is on my test bench as a more powerful replacement. They all, indiscriminately, run OpenWrt.


Doesn't work. Tried numerous times, following different sequences, etc. - No changes with my E4200 v1.
Hence, I will have to go with Serial Connection + TFTP, and if not working - JTAG.
Will see soon... I'm still expecting my USB connector.