Bricked Cudy X6 v2

Hello Guys. I'm new here but i have one issue. I had installed OpenWRT on my Cudy X6 v2 but i wanted to restore it to original firmware. Like you can assume by the title i just does it like any other openwrt flash which went horribly wrong and now my device doesn't even boot properly.

If i power it up normally i have purple light for a sec then just red with no reply from router. I tried that TFTPD method but i doesn't recognize my device. (Disc. When i does that reset mode thing (holding reset then pluging in power) i have just purple light without any bliking. I will be greatful for any tip how i can manage to make it work.

there's nothing to recognize, but your TFTP host settings are probably wrong.
look at https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e38de40f8dd350344407fe5a91e81191f6960804

https://openwrt.org/toh/cudy/x6#serial is always a safe bet, even though it doesn't seem to be required in this case.

1 Like

That's my settings for TFTPD

image

I can't drop "GET" cause it gaves me "timeout" put stucks just on Block#0

You're serving, not pushing.

Ok my bad i did everything excaly like in that Cudy tutorial for restore.

My Network interface IP is 192.168.1.88
Net Mask : 255.255.255.0

But that tutorial says first run tp.. then power router.
If i run it without powered router my interface in it is.

image

But still after trying to flash it it founds nothing.

yeah, because it's using the wrong interface.

you need to make sure your interface is the static IP you had set.
but, when you power off the router it'll revert back to 127.0.0.1, so
be ready to change it to 192.x.x.x again, or put a switch or other
network device between the TFTP host and the Cudy.

I tried with that old version and newer too. When i connect if change interface to 1.88 it will stay still even after disconnecting but still doesn't shown my device. Idk if i'm that dumb or i bricked it hard. Manual says it will be red and blue blinking waiting for flash i have only static pruple led.

it doesn't show anything until a DL's actually taking place.

can't help you there, sorry.

like I said, safest way is to hook up the serial console.

I solved that issue.
What worked for me was USB -> Ethernet adapter cause it's always active.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.