Bricked ArcherC50 V4, router not starting after boot

Hello There (I am new to router flashing and recovery), I installed the latest release of openwrt, after 2 mins from installing I rebooted the router found that my router got bricked. I came upon the failsafe recovery page and tried soft reset. After pressing the reset button all LEDs turned off except WIFI (2.4Ghz) and it started flashing rapidly. So I turned off the router and powered on. I found out that there was no LED glowing nor any connection to ethernet port. Disassembled the router and check for power input. Luckily router has power but no response. Tried Identifying Serial pin-out but getting same voltage reading on two pins. NO TFTP, NO WIFI, NO ETHERNET CONNECTIVITY.

Did you modify sysupgrade.bin file before flashing to C50 v4 described in the wiki ?
Did you use tplink UI or TFTP to originally install the file?

Unless someone else can offer another suggestion, I suggest you set up a TFTP server and use it to serve the 'tp_recovery.bin' contained in the pre-built images for 'OpenWRTforArcherC50v4(EU).zip'. This will install an early snapshot of openwrt to the C50 v4.

Installing via TFTP
File required:  tp_recovery.bin

Place tp_recovery.bin in root directory of TFTP server and listen on

Connect router LAN ports with your computer and power up the router
while pressing the reset button. The router will download the image via
tftp and after ~1 Minute reboot into OpenWRT.

Ethernet not working. So can't use TFTP server. Serial and JTAG are the only option. Don't know how to use JTAG and have hardware to use serial console. No LEDs are powering on and laptop doesn't detect ethernet connected to router. Did modified the sysupgrade file as suggested in the wiki

Had the same situation with asus ac57u v2. Ended up soldering 3 pins to the board, using 3.3v USB 3 pin serial cable to wire it to computer, then gtkterm connected with it (googled how), got to UBOOT console (it allows you to choose an option at boot for... 1 second :D, so you have to be quick) and then transferred a stock image via tftp (also googled how).

Balance: wasted 10 hours, $200+, and learned how to solder stuff. Kinda interesting, but I don't have these amounts of time to spare any more :frowning:

I can share my experiences.

Soldered the 3 pins and used arduino and USB TTL. But no luck can't get a console. Got ground pin and having confusion between Vcc and TX pin coz of almost same voltage across them 3.39 and 3.34 respectively. As said in wiki there would be a voltage fluctuation across the TX pin, but I dont see any voltage fluctuation across those two pins. And from different router tutorials I came to conslusion that most of the time a thicker border has TX pin. So tried this config. Saw some tutorial about different routers, they shorted one or two connections to get access to serial console. But I don't know any kind of those pins that allow serial access. Without those shorting pins I tried accessing the serial console. No output on the console. Still no luck. Need a serial pinout details for the router to access the serial console

A post was split to a new topic: Archer A5 v4 bricked