Bricked Archer C7 beyond repair? only power led is on

So I was actually installing the official firmware but something went wrong on the update and now my router when restarted blinks once and then just has the Power led on and the network leds on. The second led, 'system' is always off which the manual says is pretty bad.

I tried to unbrick using TFTP but it never communicates with the pc, actually it seems when it starts it never enters the 'recovery' mode since the system led is off.

Is this broken behind any repair or I can try something else? Anyone had a C7 with system led OFF and managed to revive it?

Serial console access would be needed to be sure, however - recovering over serial console also depends on the bootloader to (still) be in working order, but if it were, the push-button tftp recovery should be functional as well…

The resale value of a fully functional, used archer c7 is somewhere around 40-45 EUR/ USD (which imho already is a bit too much for a device of this vintage, but prices are inflated for a slightly hyped product like this); new devices sell for around 75 EUR/ USD.

  • 3.3V USB serial console, around 5 EUR/ USD sourced locally, ~1.50 EUR/ USD with slow shipping from china
  • 4-pin header && jumper cables, ~2 EUR/ USD
  • soldering equipment >20-25 EUR/ USD (soldering iron, some soldering tin, solder wick and vacuum pump), easily more than that
  • ch341a SPI flasher && SOIC-8 clamp, ~15 EUR/ USD

If you can't get push-button tftp going, you need at least the first two items to get an idea what's happening (soldering equipment recommended, but you may be able to get along with just the pins and cables for temporary usage).

If the bootloader is shot, you really do need soldering equipment and the SPI flasher/ SOIC-8 clamp - while this will allow you to reflash bootloader and firmware, you still need to hope that your wireless calibration data (which is unique to your device) isn't corrupted/ overwritten, without correct calibration data the wireless functionality would be gone for good.

Depending on your experience and the equipment you already have (or have a need for beyond just recovering a single router), you have to do the math up to which point it's economically viable to invest into the potential to recover your device (even though it might have lost its wireless capabilities). Other than the archer c7, you may find quite decent devices on the used market for rather little money (10-25 EUR actually go a long way), this requires some patiences and luck, of course.

if you own a RPi or some other devboard with 3.3V based UARTs, you could use that to access your router's serial console instead of buying a dedicated USB2serial adapter (although that would be more convenient).

1 Like

To get into pushbutton recovery, hold down the reset button while turning the power on. After several seconds the WPS light (on the far right side opposite the power light) should come on. If it does that, the bootloader is still working and it should be possible to recover.

I don't think the system light is supposed to come on until out of the bootloader, so a regular brick (kernel can't boot) will have it not come on.

1 Like

If you are not taking the route slh suggested please consider selling it on ebay or any platform of your choice so someone with time, equipment and lust can get a chance.

PS: With an detailed description of course so everyone knows what to expect


I tried that, powered on the thing with WPS/reset pressed and power on. leds flash for a brief second and then nothing happens, only power led on forever....

thank you very much. yeah, that was my thought process also: if TFTP recovery doesn't work, probably serial recovery is also broken because the thing doesn't 'boot'...

I don't have much hope serial recovery would yield any results. I'll try to annoy tp-link support because this was bullshit: i was just installing a stock C7 with a stock C7 firmware! it's out of warranty but still....

I'll still buy the usb-serial from china just to have it around but I'll have to ask a friend to even solder the pins on the router so, yeah, not an expert on hardware for sure :slight_smile:

I'll just wait for more feedback to see if the System light being off can mean 'just' a broken firmware salvageable from TFTP recovery or serial or if means the bootloader is broken and I for sure can't flash the chip