Bricked Archer C50 V4Router After installing openwrt firmware


I have an TP-LINK Archer C50 V4 Router, downloaded Openwrt file from the website and uploaded it to the router, the router stopped working, i tried to recover it using TFTPD and i followed the steps as mentioned, but only the power light works and the router is not booting, i'm not good in programming stuff and i need your help to resolve this issue.

Many thanks,

What file and method did you use to install openwrt?

Try this stripped firmware posted by @pnlshd to unbrick it.

i installed 19.07.03 from the web interface then the router bricked. then i downloaded the origional firmware and tried to install it with tftpd i put the router on recovery then the software upliaded to the router. but only the power led was on. i will try the stripped firmware and let you know.

the file worked fine. thank you soooo much

Yes, installing the 19.07.3 sysupgrade.bin 'upgrade' file using tplink web UI will indeed brick the C50 v4.

There are specific openwrt installation instructions for the C50v4 in the wiki page. Pre-built files for first time openwrt install are available for the v4.
ie. use the pre-built 'boot.bin' via TPlink web UI. Then install 19.07.3 sysupgrade file via LuCI.

Pleased to read @pnlshd recovery file helped to unbrick your C50 v4.

Please mark this thread as Solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.