Branch 'master' break 802.11r r0kh and r1kh for WPA2-EAP(uci/luci forced ft_psk_generate_local '1')

I have tried to add r0kh and r1kh in LuCI interface but it won't apply.And then I tried to add r0kh and r1kh manually to config files,r0kh and r1kh showed up in luci,but in hostapd-phy0.conf it didn't include the r0kh and r1kh.

I just thought that maybe the uci's or luci's bug,and yes,after putting "option ft_psk_generate_local '0'" to config and restart wireless,everything is fine,but I can't touch wireless in luci,because it will erase "option ft_psk_generate_local '0'" in config file.And I don't know where to submit this bug.

Well, the bug is actually caused by a change in our defaults a few months ago in the WiFi driver, when the psk_generate_local default was changed in a way that rendered previous configs partially inactive. Luci still thinks that the old default value is valid and need to be fixed. The was a PR about this, but the author did not complete the work. I can look into it.

1 Like

See the first fix:

Ps. I also backported that to 18.06

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.