BPI-R64 - Snapshot has wrong kernel version listed

On current snapshot for the BPI-R64 (and probably all other MT7622 devices), when you build it it thinks it still has kernel version 5.15.88, even though it actually has the current 5.15.89. You therefore can't install any kernel modules, because all the modules you can download are expecting 5.15.89, but the build thinks it has version .88. The kernel version number needs to be updated for the kernel package.

Are you building your own snapshots (which snapshots btw, master, 22.03?) image (how btw, toolchain, sdk?) and trying to install kernel modules from OpenWrt repo?

Yes. Building snapshot (master). It recently went from 5.15.88 to .89. The actual kernel version from uname within the build is 5.15.89, but the kernel package within OpenWrt is still versioned 5.15.88. This is preventing opkg from installing kernel modules because opkg wants the kernel package version to be 5.15.89.

Looks like the kernel was updated and someone forgot to increment the package version.

you will never be able to install packages with kernel dependencies from the repositories on your own build, even if the kernel version matches.

2 Likes

That isn't corrrect. Many people do it regularly. That is, when the kernel package version is set right. There is nothing magic about the official builds that lets them do it.

In general you just have to base your build off the official config for your device. You can check to make sure your kernel hash matches by downloading your device's manifest and then checking your build's kernel hash with:
find build_dir/ -name .vermagic -exec cat {} \;

There is a great little article about it here: https://hamy.io/post/0015/how-to-compile-openwrt-and-still-use-the-official-repository/

Well, I tried, and failed, but it was some time ago.

Error might have been on the long side of the keyboard where the wire isn't attached.

If you want to try again, it looks like the version issue has been fixed. Snapshot builds are coming out with the correct kernel package version label now.

Simply a matter of it takes time, it is not an error as the buildbots require a lot of time to do their thing. But of course you should expect the vermagic to be out of sync.

The real question is, if building your own why would you not build the complete image as you run it, i.e. everything included.

1 Like

I've seen the buildbots behind, this was just new to me. Normally I've experienced the version number being incremented in the builds and it's still the old version in the respositories. This time it was reversed - the repositories were incremented and the snapshot wasn't. Though, now that I think about it, I expect they were just trying to give the buildbots time to finish for every platform before upping the package version number. Fair enough - I'll be more patient next time. :slight_smile:

"As I run it" tends to be a moving target. I suppose I should start building my own repository with a complete set of packages (certainly a complete set of kernel modules) - I just haven't gotten there yet.

Thanks!

If you trust OpenWrt buildbots to compile packages are there trust or technical issues preventing you from using the OpenWrt Image Builder so you don't have to compile your own image?

Technical. For my device (mt7622-based BPI-R64), there is a long-standing bug (identical to this one except on the mt7622) that hamstrings performance that I patch around. I also patch in an enhancement for mt76 (to allow eeprom setting from a file), and bug fixes for perl that haven't made it in yet. Plus increase the size of the (in my opinion) unfathomably small overlay.

I also just enjoy getting my hands dirty. :slight_smile:

1 Like