bpi-R3 Initial Install, serial port not working

I got my shiny new BPI-R3, but I can't get the serial port to work or otherwise get to any CLI/WebUI.

  • I've followed the guide
  • dmesg confirms /dev/ttyUSB0 gets assigned when I plug it in.
  • I've tried both screen and minicom to /dev/ttyUSB0 @ 115200, 8N1. Screen is blank, minicom reports offline.
  • I'm pretty sure it's booting to openwrt because if I plug a cable in to the WAN port and listen with tcpdump on the other end, I see dhcp requests with Hostname=openwrt.
  • I can assign it an IP, but nmap confirms there are no open ports.
  • If I try with on of the LAN interfaces, I see the DHCPDISCOVER and see my server's DHCPOFFER, but I never see the DHCPREQUEST.

Does anyone have a BPI-R3 working? Any hints? I think I just need to get the serial port working so I can copy the image from the sdcard to eMMC, but I must be missing a jumper or something.

I figured it out. On the USB to TTL, the TX goes to the RX on the board and visa versa. Not TX<->TX, RX<->RX.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile: