Bought a TP-Link Archer C7 v2, however

Today I received the new bought second-hand TP-Link Archer C7 v2, which is labeled as CleanRouter. I cannot enter the web configure page.

The router ip seems to be, I just couldn't find the default password to enter the http configuration page. The https page, however, showed as ZyXEL.

While I am asking the seller for the password or the way to enter the webpage. I wonder if anyone has ever successfully flashed LEDE firmware with it?

Or any suggestions?

Stock TP-Link firmware IP is User ID and password is admin.

LEDE is User ID is root. No password until you set one up.

You may need to do a hard factory reset and configure it from scratch (which is a good idea on a used router anyway).

could try TFTP recovery to a stock LEDE image.

Done that, so far without success, unfortunately.

The TFTP works when I set the local IP of the computer to, the router got bricked (flash with some kind of pattern repeatedly).

Tried both official firmware and LEDE, neither worked.

What other options do I have?

If you are using TFTP, the router is expecting the firmware file to be named ArcherC7v2_tp_recovery.bin


There was something about cutting the firmware that was needed with tftp. Or maybe that was only with stock firmware.

That is for going back to stock from LEDE using the LEDE GUI.

Stripped TP-Link firmware can be found on

I've used both the FriedZombie firmware and TFTP on an Archer C7 v2. Both work.

Serial is a last resort.

Just tried the stripped version with tftpd32, still it doesn’t work.

There’s only the Lan port led flashing now.

The stripped version is only for flashing from the OpenWRT/LEDE GUI.

Try doing a hard reset to get back to the original stock firmware.

If that doesn't work, download the latest stock TP-Link firmware, rename it as mentioned above, and try to flash it using TFTP.

Failing that, your last resort is to flash using a serial connection.

Thank you guys for your kind help.

Eventually I have to return that apparently OEM one. Now I got another v2 via craigslist, hope it works this time.